summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-04-30 20:03:24 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-02 13:54:11 +0200
commit8ddc2070e5adb146d988e988d843fe65fd8e42a2 (patch)
treef34182249958edf8124b9b28c6093fd8cdfebd4e /sci-physics/hepmc
parentdev-libs/libcec: Fix udev rule (diff)
downloadgentoo-8ddc2070e5adb146d988e988d843fe65fd8e42a2.tar.gz
gentoo-8ddc2070e5adb146d988e988d843fe65fd8e42a2.tar.bz2
gentoo-8ddc2070e5adb146d988e988d843fe65fd8e42a2.zip
sci-physics/hepmc: Add fortran and numpy deps
Closes: https://bugs.gentoo.org/905129 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/Manifest1
-rw-r--r--sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild (renamed from sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild)13
2 files changed, 11 insertions, 3 deletions
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
index ba98b1642ec6..0520bcb6914e 100644
--- a/sci-physics/hepmc/Manifest
+++ b/sci-physics/hepmc/Manifest
@@ -1,4 +1,5 @@
DIST HepMC-2.06.09.tar.gz 4612637 BLAKE2B 6bbf1a6a8410b6717ddff29fc3643247582f7a61a05fd9e52a0b09f78bf75de587c1c55525f6a1367b306a26a4687ce55b64908c049d91bdb2db3d40467af62b SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4
DIST HepMC3-3.2.5.tar.gz 9217649 BLAKE2B 520e4621cdfa277376e94b87a070f23e6479867bbf696dc972e7496c54504c7da921932fbeaf7713cbaab18c72101ad3fa79396fe8ee1737180946696dcd1fbd SHA512 de60aaa686f6499c62112c265438b9ba41a7ed312b767ddc3409178b6e908e4fffd6a1153bd9f2929cf479074b14bcbec33d377f51a11cfcd4c67e45fc9bb2b9
+DIST HepMC3-3.2.6.tar.gz 9344806 BLAKE2B da478157ad73915d77851e9da7b236a052cb32e98103c2701f874a81ed62cbc4397489e3a2f64cd25a46c9704ccfcaac4d854357251d8bbb4120cbc1f5149374 SHA512 d8a50f081db109c9c18e4aaee60230be062eaa2947dadfb14759649eb1c504975802b2c822b1fe024d4e73f703e9f399161fa4fe38b526722dda33c2ff2e8fab
DIST HepMC3-e05d32ebac8705c0097e9e7d00ce815a205110db.tar.gz 9346161 BLAKE2B 9304d329332c2d4eb0ef6526a3308aecd29a38c569d3ba57d94767fd38ad052514f75a7a90f301c54185230d7693a67e48d59b66b12f42626a7ef900e309f743 SHA512 45f9edc6c56f9f8494b416bff147dccca64c52a90e0e169ede560ae8cf9e9255258b7af1586dd1c856f4010c22b2e668511bab160487a3ba802b629d03015e55
DIST hepmc2.06.11.tgz 4893958 BLAKE2B ac8eef250cb330a167c9e0f4bd1aaf8df82e0ffec3557ab5cdaf8bc5b0b7333d6a45f73710ce63abab52d2c5758d5663c15c2a7c940a09504b3ef2fd4517aa0b SHA512 81c100d4931e0e4de62c8ffd18cc06e7996a642fecc092892988bdc0dd0dc3c0f5b336e85f09ceb8f5e0e09456775ae5928d37daf28d82923476089bc0e910f2
diff --git a/sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild b/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
index 4f6201190a03..e61cb750aa34 100644
--- a/sci-physics/hepmc/hepmc-3.2.5_p20230225.ebuild
+++ b/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake python-single-r1
+inherit fortran-2 cmake python-single-r1
MYPN=HepMC3
MYP=${MYPN}-${PV}
@@ -28,7 +28,14 @@ IUSE="doc test examples python root"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
DEPEND="${RDEPEND}"
BDEPEND="
root? ( sci-physics/root:= )
@@ -54,5 +61,5 @@ src_configure() {
src_install() {
cmake_src_install
use examples && docompress -x /usr/share/doc/${PF}/examples
- python_optimize
+ use python && python_optimize
}