summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2016-01-05 20:45:53 +0100
committerJauhien Piatlicki <jauhien@gentoo.org>2016-01-05 20:49:36 +0100
commit0d526d437a5e992acdd7c86fa757aa0a0ca3a34c (patch)
treedcea141b773ba95e7000ae1bf70b722151884a1d /sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
parentsci-libs/libbufr: Updated to latest release and removed old version (diff)
downloadgentoo-0d526d437a5e992acdd7c86fa757aa0a0ca3a34c.tar.gz
gentoo-0d526d437a5e992acdd7c86fa757aa0a0ca3a34c.tar.bz2
gentoo-0d526d437a5e992acdd7c86fa757aa0a0ca3a34c.zip
sci-physics/herwig++: fix sci-physics/thepeg dependency
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-physics/herwig++/herwig++-2.7.1-r1.ebuild')
-rw-r--r--sci-physics/herwig++/herwig++-2.7.1-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..9777789bb27b
--- /dev/null
+++ b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils eutils flag-o-matic multilib
+
+MYP=Herwig++-${PV}
+
+DESCRIPTION="High-Energy Physics event generator"
+HOMEPAGE="http://herwig.hepforge.org/"
+SRC_URI="http://www.hepforge.org/archive/herwig/${MYP}.tar.bz2"
+
+SLOT="0/15"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="c++11 fastjet static-libs"
+
+# >sci-physics/looptools-2.8 leads to misoperation
+# and failing tests (it lacks some symbols)
+RDEPEND="
+ dev-libs/boost:0=
+ sci-libs/gsl:0=
+ <=sci-physics/looptools-2.8:0=
+ ~sci-physics/thepeg-1.9.2:0=
+ fastjet? ( sci-physics/fastjet:0= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.3-looptools.patch
+ find -name 'Makefile.am' -exec \
+ sed -i -e '1ipkgdatadir=$(datadir)/herwig++' {} \; || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use prefix && \
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/ThePEG
+ local myeconfargs=(
+ --with-boost="${EPREFIX}"/usr
+ --with-thepeg="${EPREFIX}"/usr
+ $(use_enable c++11 stdcxx11)
+ $(use_with fastjet fastjet "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ sed -i -e "s|${ED}||g" "${ED}"/usr/share/herwig++/defaults/PDF.in || die
+ sed -i -e "s|${ED}||g" "${ED}"/usr/share/herwig++/HerwigDefaults.rpo || die
+}