summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-08-31 08:40:12 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2015-08-31 08:40:12 -0600
commit3277d583c52240a79494bca8ef6e3df41e2dbeb9 (patch)
tree0903572629c7274757a9ae8842ba8ce5d1fd5b56 /sci-physics/lammps
parentsci-physics/lammps: Version bump. (diff)
downloadgentoo-3277d583c52240a79494bca8ef6e3df41e2dbeb9.tar.gz
gentoo-3277d583c52240a79494bca8ef6e3df41e2dbeb9.tar.bz2
gentoo-3277d583c52240a79494bca8ef6e3df41e2dbeb9.zip
sci-physics/lammps: Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-physics/lammps')
-rw-r--r--sci-physics/lammps/Manifest1
-rw-r--r--sci-physics/lammps/lammps-20150829.ebuild267
2 files changed, 268 insertions, 0 deletions
diff --git a/sci-physics/lammps/Manifest b/sci-physics/lammps/Manifest
index 17bb0ea36c4e..978a7fb01699 100644
--- a/sci-physics/lammps/Manifest
+++ b/sci-physics/lammps/Manifest
@@ -10,4 +10,5 @@ DIST lammps-21Jul15.tar.gz 66715434 SHA256 2e24a7b6131a35ef83cec08f4dc9f7cc5188c
DIST lammps-22Jul15.tar.gz 67275212 SHA256 b75cdf8ead17f20433737c203c8d29c0cc3e157c9b3d175093467873aea0b869 SHA512 f6e5eaf3ca8bcd25a580a4608e0aec0021f2ed5eb23cf9ccd0a707cb8bc320568504ccffc25cccb5acfe2fc3515c58f8afc8936aea63acb3062bdc897a5eb2ee WHIRLPOOL 13c09e1045a0bdabe15e2125ccef0ea622cb12fcce63d8441b7f9843b8f1a3f7aa0c13908a2e215c1fdba8a579a17a5833111b5cf31a2471bf66e781ef281c59
DIST lammps-24Jul15.tar.gz 67180142 SHA256 bd183f7b073e1ca86656a8f6ea99195123ce3c7829c872ca45216da4132ff96d SHA512 e285a1f326658bd23f32ecf9409d9f0bf16ed635656bbcee0d84da58e1c008363c7815001bcaa5b7701d99b3318a56240b021447e94754607c2ceb178e377122 WHIRLPOOL 003237f8e9a7caec98aa1f8f0c5e03c0cda6d60f20460e32c4eea3c92707e349f4e1a71510f1290b6e6aeac1621951080f904b1bb2224c8eb9e25067206d2b1b
DIST lammps-28Apr15.tar.gz 63883556 SHA256 6e7c32690cf8bb5a4fb147bab6029cc1d03594ec7b3ea3833e7dc89acc596d8a SHA512 414c786e8666cddd31a3200baedc76974371280dc219636914dd7863f03e32e11f637a9c184af78d8d4da22afe4cf734b6a0eb32c78d6f53ee95d796a3e080c0 WHIRLPOOL c57a91f9d5e977d26cdb2076b5bbd2f3b5791396c23b5326f16cc609b9646e80c602a492b312b4e5f78d1d638c4a6b66e9a49b1ced02274ad7202821a2884975
+DIST lammps-29Aug15.tar.gz 87253305 SHA256 fff69b47c40936d4ccd90a8443ce5bb1bcf4cb449ae06a5822c1b11a2ab2dd67 SHA512 991c56608a3288ebdcd2fb0857c595d42047b5ed0780b6d4ddb98388627499727b6c04fe0eff3e7221238dba2a8601f0b4b4067b5aa5ec2f356b4ee13f6c129c WHIRLPOOL 88da74fa65aeb187330439417512d516fe8adf4a5df4be48fdafafa198e8c4d657ecce7f04f749d77cb2f8a7881ac47f4604cf6bc8eb3ca8b2cbc7988d866a87
DIST lammps-30Apr15.tar.gz 63892754 SHA256 d4a193fd5aa9417ec9d15a3be1e2b149302aacf3d9321886a806b0f4ca91611e SHA512 889fc315719e6f50f802b72a8a0c6e6d7eedb84b67e8b39ae9ea93feb2d526914639848cbfbcbb6dd8b8718c3b332f617f001c6ef04fe14d0685106fcac821bd WHIRLPOOL a681662a0c37fcb701ced8f2cd4f085dfd0ff250faac2c62abd07b718e3bf12ddbf366f725fbc21bc4547e6ef3ca3042ee84571a1fa0277a4c3d7d273ccaa099
diff --git a/sci-physics/lammps/lammps-20150829.ebuild b/sci-physics/lammps/lammps-20150829.ebuild
new file mode 100644
index 000000000000..1a244c83975e
--- /dev/null
+++ b/sci-physics/lammps/lammps-20150829.ebuild
@@ -0,0 +1,267 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+ case $1 in
+ 01) echo Jan
+ ;;
+ 02) echo Feb
+ ;;
+ 03) echo Mar
+ ;;
+ 04) echo Apr
+ ;;
+ 05) echo May
+ ;;
+ 06) echo Jun
+ ;;
+ 07) echo Jul
+ ;;
+ 08) echo Aug
+ ;;
+ 09) echo Sep
+ ;;
+ 10) echo Oct
+ ;;
+ 11) echo Nov
+ ;;
+ 12) echo Dec
+ ;;
+ *) echo unknown
+ ;;
+ esac
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+DEPEND="
+ mpi? (
+ virtual/blas
+ virtual/lapack
+ virtual/mpi
+ )
+ gzip? ( app-arch/gzip )
+ sci-libs/voro++
+ python? ( ${PYTHON_DEPS} )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE=$(tc-getAR) \
+ CC=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ F90=$(usex mpi "mpif90" "$(tc-getFC)") \
+ LINK=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC=$(usex mpi "" "-I../STUBS") \
+ MPI_PATH=$(usex mpi "" "-L../STUBS") \
+ MPI_LIB=$(usex mpi "" "-lmpi_stubs") \
+ user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+ "$@"
+}
+
+lmp_activate_packages() {
+ # Build packages
+ lmp_emake -C src yes-asphere
+ lmp_emake -C src yes-body
+ lmp_emake -C src yes-class2
+ lmp_emake -C src yes-colloid
+ lmp_emake -C src yes-coreshell
+ lmp_emake -C src yes-dipole
+ lmp_emake -C src yes-fld
+ #lmp_emake -C src yes-gpu
+ lmp_emake -C src yes-granular
+ # Need OpenKIM external dependency.
+ #lmp_emake -C src yes-kim
+ # Need Kokkos external dependency.
+ #lmp_emake -C src yes-kokkos
+ lmp_emake -C src yes-kspace
+ lmp_emake -C src yes-manybody
+ lmp_emake -C src yes-mc
+ lmp_emake -C src yes-meam
+ lmp_emake -C src yes-misc
+ lmp_emake -C src yes-molecule
+ #lmp_emake -C src yes-mpiio
+ lmp_emake -C src yes-opt
+ lmp_emake -C src yes-peri
+ lmp_emake -C src yes-poems
+ lmp_emake -C src yes-qeq
+ lmp_emake -C src yes-reax
+ lmp_emake -C src yes-replica
+ lmp_emake -C src yes-rigid
+ lmp_emake -C src yes-shock
+ lmp_emake -C src yes-snap
+ lmp_emake -C src yes-srd
+ lmp_emake -C src yes-voronoi
+ lmp_emake -C src yes-xtc
+
+ if use mpi; then
+ lmp_emake -C src yes-user-atc
+ fi
+ lmp_emake -C src yes-user-eff
+ lmp_emake -C src yes-user-fep
+ use mpi && lmp_emake -C src yes-user-lb
+ lmp_emake -C src yes-user-phonon
+ lmp_emake -C src yes-user-sph
+}
+
+lmp_build_packages() {
+ lmp_emake -C lib/meam -j1 -f Makefile.gfortran
+ lmp_emake -C lib/poems -f Makefile.g++
+ lmp_emake -C lib/reax -j1 -f Makefile.gfortran
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++
+}
+
+lmp_clean_packages() {
+ lmp_emake -C lib/meam -f Makefile.gfortran clean
+ lmp_emake -C lib/poems -f Makefile.g++ clean
+ lmp_emake -C lib/reax -f Makefile.gfortran clean
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i \
+ -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+ -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+ lib/voronoi/Makefile.lammps || die
+
+ # Fix missing .so name.
+ sed -i \
+ -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+ src/MAKE/Makefile.serial || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile || die
+
+ # Patch python.
+ epatch "${FILESDIR}/lammps-python3.patch"
+ epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+ # Fix atc...
+ append-cxxflags -I../../src
+
+ # Acticate packages.
+ elog "Activating lammps packages..."
+ lmp_activate_packages
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ if use static-libs; then
+ # Build static library.
+ elog "Building static library..."
+ lmp_emake -C src mode=lib serial
+ fi
+
+ # Clean out packages (that's not done by the build system with the clean
+ # target), so we can rebuild the packages with -fPIC.
+ elog "Cleaning packages..."
+ lmp_clean_packages
+
+ # The build system does not rebuild the packages with -fPIC, adding flag
+ # manually.
+ append-cxxflags -fPIC
+ append-fflags -fPIC
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ # Build shared library.
+ elog "Building shared library..."
+ lmp_emake -C src mode=shlib serial
+
+ # Compile main executable. The shared library is always built, and
+ # mode=shexe is simply a way to re-use the object files built in the
+ # "shlib" step when linking the executable. The executable is not actually
+ # using the shared library. If we have built the static library, then we
+ # link that into the executable.
+ elog "Linking executable..."
+ if use static-libs; then
+ lmp_emake -C src mode=exe serial
+ else
+ lmp_emake -C src mode=shexe serial
+ fi
+
+ # Compile tools.
+ elog "Building tools..."
+ lmp_emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+ use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+ newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+ newbin src/lmp_serial lmp
+ dobin tools/binary2txt
+ dobin tools/chain
+ dobin tools/data2xmovie
+ dobin tools/micelle2d
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ insinto "/usr/include/${PN}"
+ doins -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+ insinto "/${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ # Install python script.
+ use python && python_foreach_impl python_domodule python/lammps.py
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}