summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-09-27 10:07:38 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-09-27 15:40:45 +0200
commite912bed98474f247e78205f2eaf741fd765e65fb (patch)
treee66e979dfc09042d3b5d5b2f8775b8eb55e4749b /sci-physics/lhapdf/lhapdf-6.2.3.ebuild
parentx11-themes/gargantuan-icon-theme: gnome2-utils => xdg-utils (diff)
downloadgentoo-e912bed98474f247e78205f2eaf741fd765e65fb.tar.gz
gentoo-e912bed98474f247e78205f2eaf741fd765e65fb.tar.bz2
gentoo-e912bed98474f247e78205f2eaf741fd765e65fb.zip
sci-physics/lhapdf: version bump to 6.2.3 and use EAPI 7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/lhapdf/lhapdf-6.2.3.ebuild')
-rw-r--r--sci-physics/lhapdf/lhapdf-6.2.3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sci-physics/lhapdf/lhapdf-6.2.3.ebuild b/sci-physics/lhapdf/lhapdf-6.2.3.ebuild
new file mode 100644
index 000000000000..f55cef4113b9
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-6.2.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+MY_PV=$(ver_cut 1-3)
+MY_PF=LHAPDF-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://lhapdf.hepforge.org/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_configure() {
+ econf $(use_enable python)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ emake all $(use doc && echo doxy)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ emake -C tests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc -r doc/doxygen/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc
+ fi
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_install
+ fi
+}
+
+pkg_postinst() {
+ elog "Download data files from:"
+ elog "http://www.hepforge.org/archive/${PN}/pdfsets/$(ver_cut 1-2)"
+ elog "and untar them into ${EPREFIX}/usr/share/LHAPDF"
+}