summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-10-30 13:22:36 +0100
committerDavid Seifert <soap@gentoo.org>2016-10-31 09:04:02 +0100
commitb8a1d8bb027d111d70808d6456df5662fa1ff4a6 (patch)
treee94aef720b4a501bd2b5cafde9c0e2dda207be28 /sci-physics/meep/meep-1.3.ebuild
parentdev-python/nbconvert: Fix test call and dependencies (diff)
downloadgentoo-b8a1d8bb027d111d70808d6456df5662fa1ff4a6.tar.gz
gentoo-b8a1d8bb027d111d70808d6456df5662fa1ff4a6.tar.bz2
gentoo-b8a1d8bb027d111d70808d6456df5662fa1ff4a6.zip
sci-physics/meep: Version bump to 1.3, EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2699 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics/meep/meep-1.3.ebuild')
-rw-r--r--sci-physics/meep/meep-1.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-physics/meep/meep-1.3.ebuild b/sci-physics/meep/meep-1.3.ebuild
new file mode 100644
index 000000000000..8d0317c11dd1
--- /dev/null
+++ b/sci-physics/meep/meep-1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simulation software to model electromagnetic systems"
+HOMEPAGE="http://ab-initio.mit.edu/meep/"
+SRC_URI="http://ab-initio.mit.edu/meep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples hdf5 guile mpi"
+
+RDEPEND="
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ sci-physics/harminv
+ guile? ( >=sci-libs/libctl-3.2 )
+ hdf5? ( sci-libs/hdf5:= )
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2-pc-no-ldflags.patch
+ "${FILESDIR}"/${PN}-1.2-no-auto-mpb.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with mpi) \
+ $(use_with hdf5) \
+ $(use_with guile libctl)
+}
+
+src_test() {
+ # pml test buggy with optimization on
+ # http://thread.gmane.org/gmane.comp.science.electromagnetism.meep.general/4579
+ emake -C tests pml CXXFLAGS="-O0"
+ emake check
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}