summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-11-06 22:14:51 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-07 08:56:55 +0100
commit0ba691577bee7524935b29f5896830313f9e012e (patch)
tree12ca6d918e6da8c4e2891a9dd67bf159b143d148 /sci-physics/siscone/siscone-3.0.3.ebuild
parentdev-python/flask-pymongo: fix docbuild patch to apply with -p1 (diff)
downloadgentoo-0ba691577bee7524935b29f5896830313f9e012e.tar.gz
gentoo-0ba691577bee7524935b29f5896830313f9e012e.tar.bz2
gentoo-0ba691577bee7524935b29f5896830313f9e012e.zip
sci-physics/siscone: Version bump to 3.0.3, EAPI bump 5 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2764 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics/siscone/siscone-3.0.3.ebuild')
-rw-r--r--sci-physics/siscone/siscone-3.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-physics/siscone/siscone-3.0.3.ebuild b/sci-physics/siscone/siscone-3.0.3.ebuild
new file mode 100644
index 000000000000..a82f8399f551
--- /dev/null
+++ b/sci-physics/siscone/siscone-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Hadron Seedless Infrared-Safe Cone jet algorithm"
+HOMEPAGE="http://siscone.hepforge.org/"
+SRC_URI="http://www.hepforge.org/archive/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{cpp,h}
+ docinto examples/events
+ dodoc examples/events/*.dat
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}