summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-16 23:48:05 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-16 23:48:39 +0200
commit01efefbfe2fdd43591ee336fb46c02a25a714254 (patch)
tree047c900f521a03c7aee8fb67a22673e311183bba /sci-physics
parentdev-libs/xmlsec: cleanup ebuild (diff)
downloadgentoo-01efefbfe2fdd43591ee336fb46c02a25a714254.tar.gz
gentoo-01efefbfe2fdd43591ee336fb46c02a25a714254.tar.bz2
gentoo-01efefbfe2fdd43591ee336fb46c02a25a714254.zip
sci-physics/herwig++: Fix building against boost 1.70
Closes: https://bugs.gentoo.org/672250 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch42
-rw-r--r--sci-physics/herwig++/herwig++-2.7.1-r1.ebuild6
2 files changed, 46 insertions, 2 deletions
diff --git a/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch b/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch
new file mode 100644
index 000000000000..bd4579b575a0
--- /dev/null
+++ b/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch
@@ -0,0 +1,42 @@
+https://bugs.gentoo.org/672250
+
+--- a/DipoleShower/Base/DipoleChain.cc
++++ b/DipoleShower/Base/DipoleChain.cc
+@@ -15,6 +15,7 @@
+ #include "Herwig++/DipoleShower/Utility/DipolePartonSplitter.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ using namespace Herwig;
+
+--- a/DipoleShower/Base/DipoleEventRecord.cc
++++ b/DipoleShower/Base/DipoleEventRecord.cc
+@@ -19,6 +19,7 @@
+ #include "ThePEG/PDF/PartonExtractor.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ #include <algorithm>
+
+--- a/Exsample2/BinnedStatistics.h
++++ b/Exsample2/BinnedStatistics.h
+@@ -16,6 +16,7 @@
+ #include "ThePEG/Repository/UseRandom.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ namespace Herwig {
+
+--- a/Exsample2/exsample/config.h
++++ b/Exsample2/exsample/config.h
+@@ -25,6 +25,7 @@
+ #include <limits>
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+ #include <boost/scoped_array.hpp>
+ #include <boost/scoped_ptr.hpp>
+
diff --git a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
index cb49eebe72f9..33fcc97e82f2 100644
--- a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
+++ b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,7 +33,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.6.3-looptools.patch
+ epatch \
+ "${FILESDIR}"/${PN}-2.6.3-looptools.patch \
+ "${FILESDIR}"/${PN}-2.7.1-fix-boost-1.67.patch
# fixes bug 570458, which is due to an outdated bundled boost.m4
rm m4/boost.m4 || die
find -name 'Makefile.am' -exec \