summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 11:31:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:57 +0100
commit2efa53effda5472007dcfb99247d31a279b067c6 (patch)
tree723e558bd8a32d84461432bc6f278b5185e3c6ae /sci-physics
parentmedia-gfx/blender: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-2efa53effda5472007dcfb99247d31a279b067c6.tar.gz
gentoo-2efa53effda5472007dcfb99247d31a279b067c6.tar.bz2
gentoo-2efa53effda5472007dcfb99247d31a279b067c6.zip
sci-physics/root: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.12.06-r11.ebuild6
-rw-r--r--sci-physics/root/root-6.14.08-r4.ebuild6
-rw-r--r--sci-physics/root/root-6.16.00-r4.ebuild6
-rw-r--r--sci-physics/root/root-6.18.04-r1.ebuild (renamed from sci-physics/root/root-6.18.04.ebuild)6
-rw-r--r--sci-physics/root/root-9999.ebuild6
5 files changed, 25 insertions, 5 deletions
diff --git a/sci-physics/root/root-6.12.06-r11.ebuild b/sci-physics/root/root-6.12.06-r11.ebuild
index cf9543852ddf..d49c467555c2 100644
--- a/sci-physics/root/root-6.12.06-r11.ebuild
+++ b/sci-physics/root/root-6.12.06-r11.ebuild
@@ -90,7 +90,11 @@ CDEPEND="
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
tbb? ( dev-cpp/tbb )
- tmva? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ tmva? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
vc? ( dev-libs/vc )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )
diff --git a/sci-physics/root/root-6.14.08-r4.ebuild b/sci-physics/root/root-6.14.08-r4.ebuild
index 0e7b47c3c07a..86b2044fd24f 100644
--- a/sci-physics/root/root-6.14.08-r4.ebuild
+++ b/sci-physics/root/root-6.14.08-r4.ebuild
@@ -95,7 +95,11 @@ CDEPEND="
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
tbb? ( >=dev-cpp/tbb-2018 )
- tmva? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ tmva? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
vc? ( dev-libs/vc:= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )
diff --git a/sci-physics/root/root-6.16.00-r4.ebuild b/sci-physics/root/root-6.16.00-r4.ebuild
index 801efd279db0..aa5745011f80 100644
--- a/sci-physics/root/root-6.16.00-r4.ebuild
+++ b/sci-physics/root/root-6.16.00-r4.ebuild
@@ -95,7 +95,11 @@ CDEPEND="
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
tbb? ( >=dev-cpp/tbb-2018 )
- tmva? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ tmva? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
vc? ( dev-libs/vc:= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )
diff --git a/sci-physics/root/root-6.18.04.ebuild b/sci-physics/root/root-6.18.04-r1.ebuild
index 0438e31b9afb..89beda36d2b8 100644
--- a/sci-physics/root/root-6.18.04.ebuild
+++ b/sci-physics/root/root-6.18.04-r1.ebuild
@@ -91,7 +91,11 @@ CDEPEND="
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
tbb? ( >=dev-cpp/tbb-2018 )
- tmva? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ tmva? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
vc? ( dev-libs/vc:= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index a6dee45e8047..53b2390393ae 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -103,7 +103,11 @@ CDEPEND="
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
tbb? ( >=dev-cpp/tbb-2018 )
- tmva? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ tmva? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
vc? ( dev-libs/vc:= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )