summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-11-18 17:43:11 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-11-18 17:47:23 +0100
commit41c19472da8b4c9ec34e61079a82466b7b18376b (patch)
treed2c852ac2f12b6fe9f50f152958a8120f61594a6 /sci-physics
parentsci-physics/clhep: fix bug 657966 (diff)
downloadgentoo-41c19472da8b4c9ec34e61079a82466b7b18376b.tar.gz
gentoo-41c19472da8b4c9ec34e61079a82466b7b18376b.tar.bz2
gentoo-41c19472da8b4c9ec34e61079a82466b7b18376b.zip
sci-physics/clhep: move to cmake.eclass
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/clhep-2.4.1.3-r2.ebuild (renamed from sci-physics/clhep/clhep-2.4.1.3-r1.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-physics/clhep/clhep-2.4.1.3-r1.ebuild b/sci-physics/clhep/clhep-2.4.1.3-r2.ebuild
index 59a7053f2144..bca84447a5c0 100644
--- a/sci-physics/clhep/clhep-2.4.1.3-r1.ebuild
+++ b/sci-physics/clhep/clhep-2.4.1.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="High Energy Physics C++ library"
HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
@@ -31,7 +31,7 @@ PATCHES=( "${FILESDIR}"/clhep-fix-testThreaded.patch )
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
@@ -53,5 +53,5 @@ src_configure() {
-DCLHEP_BUILD_DOCS=$(usex doc)
-DCLHEP_SINGLE_THREAD=$(usex threads no yes)
)
- DESTDIR="${ED}" cmake-utils_src_configure
+ DESTDIR="${ED}" cmake_src_configure
}