summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 20:10:07 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:36 +0100
commit588795db94366812e38da84d817d8a00bd7835ed (patch)
tree927405a16696e630dce3808c506a5e44a6a570f3 /sci-physics
parentsci-mathematics/relational: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-588795db94366812e38da84d817d8a00bd7835ed.tar.gz
gentoo-588795db94366812e38da84d817d8a00bd7835ed.tar.bz2
gentoo-588795db94366812e38da84d817d8a00bd7835ed.zip
sci-physics/espresso: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/espresso-4.0.0-r2.ebuild (renamed from sci-physics/espresso/espresso-4.0.0-r1.ebuild)6
-rw-r--r--sci-physics/espresso/espresso-4.0_pre20170228.ebuild6
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/sci-physics/espresso/espresso-4.0.0-r1.ebuild b/sci-physics/espresso/espresso-4.0.0-r2.ebuild
index 00b53caa2efc..0afbf393e9a9 100644
--- a/sci-physics/espresso/espresso-4.0.0-r1.ebuild
+++ b/sci-physics/espresso/espresso-4.0.0-r2.ebuild
@@ -31,8 +31,10 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )
dev-libs/boost:=[mpi]
diff --git a/sci-physics/espresso/espresso-4.0_pre20170228.ebuild b/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
index 5755eba6cdf1..e7c540b16298 100644
--- a/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
+++ b/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
@@ -33,8 +33,10 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- >dev-python/cython-0.22[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >dev-python/cython-0.22[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )
dev-libs/boost:=[mpi]
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index b9d14d3937e5..fcc6fbc9926e 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -31,8 +31,10 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )
dev-libs/boost:=[mpi]