summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 10:20:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 22:59:40 +0100
commit68e206daf689674928f9f799db10fc761201ad9f (patch)
treeb3283fd23039e2fa01674abac50df1bd14a07b83 /sci-physics
parentsci-physics/clhep: drop 2.4.5.1 (diff)
downloadgentoo-68e206daf689674928f9f799db10fc761201ad9f.tar.gz
gentoo-68e206daf689674928f9f799db10fc761201ad9f.tar.bz2
gentoo-68e206daf689674928f9f799db10fc761201ad9f.zip
sci-physics/espresso: drop 4.1.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/Manifest1
-rw-r--r--sci-physics/espresso/espresso-4.1.3.ebuild122
-rw-r--r--sci-physics/espresso/files/espresso-4.1.3-gcc-11.patch37
3 files changed, 0 insertions, 160 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
index 949e4ac778c0..8fc3c5ca8d45 100644
--- a/sci-physics/espresso/Manifest
+++ b/sci-physics/espresso/Manifest
@@ -1,2 +1 @@
-DIST espresso-4.1.3.tar.gz 16947336 BLAKE2B 14d3513eda87f62a8473a0cac0c273b3590bf78ed48b96e76d10c106713f7bbd7d37de951bd3d9210062b34c02bd83a68f3aaf1ca8215ed1dcde590e4e99b113 SHA512 1fe82683eddb7bfd9bae6e446b0f42a50087d755995963905cd419473ad17b204f20049d0cf4af9264898dd6fee36f02744b38fa45cd0e33086374cf2aebd934
DIST espresso-4.2.0.tar.gz 14000445 BLAKE2B 79de0e364cd932e534b0e1ee9433ae90e4deeb1ade262aa6877a30c8656f03155ca77b8feafdd5607f83e36ee4f47ad7ec28be353bc3358216a9c9f8c0902323 SHA512 b80afb1bef57911fd79b88378a5b2e31b07a18d415fe17fcd5ed28fb448eeca5922f98af8df42117e9e869645765d55ecfb3aae615fa6a53c915f7d8a63081c5
diff --git a/sci-physics/espresso/espresso-4.1.3.ebuild b/sci-physics/espresso/espresso-4.1.3.ebuild
deleted file mode 100644
index 17f2fbd1addc..000000000000
--- a/sci-physics/espresso/espresso-4.1.3.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake cuda python-single-r1 savedconfig
-
-DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
-HOMEPAGE="http://espressomd.org"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
- EGIT_BRANCH="python"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}md/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="cuda doc examples +fftw +hdf5 test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
- fftw? ( sci-libs/fftw:3.0 )
- dev-libs/boost:=[mpi]
- hdf5? ( sci-libs/hdf5:=[mpi] )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-latexextra
- virtual/latex-base )"
-
-DOCS=( AUTHORS NEWS README ChangeLog )
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-11.patch
-)
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CUDA=$(usex cuda)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DWITH_TESTS=$(usex test)
- -DINSTALL_PYPRESSO=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
- -DWITH_HDF5=$(usex hdf5)
- -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
- -DCMAKE_SKIP_RPATH=YES
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
-}
-
-src_install() {
- local i docdir="${S}"
-
- cmake_src_install
-
- python_optimize
-
- insinto /usr/share/${PN}/
- doins "${BUILD_DIR}/myconfig-sample.hpp"
-
- save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
-
- if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
- newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
- newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
- for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
- newdoc "${i}" "tutorial_${i##*/}"
- done
- dodoc -r "${BUILD_DIR}/doc/doxygen/html"
- fi
-
- if use examples; then
- insinto "/usr/share/${PN}/examples/python"
- doins -r samples/${i}/.
- fi
-}
-
-pkg_postinst() {
- echo
- elog "Please read and cite:"
- elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
- elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
- echo
- elog "If you need more features, change"
- elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
- elog "and reemerge with USE=savedconfig"
- echo
- elog "For a full feature list see:"
- elog "/usr/share/${PN}/myconfig-sample.hpp"
- echo
-}
diff --git a/sci-physics/espresso/files/espresso-4.1.3-gcc-11.patch b/sci-physics/espresso/files/espresso-4.1.3-gcc-11.patch
deleted file mode 100644
index fcda88e9b8b8..000000000000
--- a/sci-physics/espresso/files/espresso-4.1.3-gcc-11.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://src.fedoraproject.org/rpms/espresso/blob/f34/f/espresso-gcc11.patch
---- a/src/core/communication.hpp
-+++ b/src/core/communication.hpp
-@@ -49,6 +49,8 @@
- * to \ref CALLBACK_LIST.
- */
-
-+#include <cstddef>
-+
- #include "MpiCallbacks.hpp"
-
- /* Includes needed by callbacks. */
-diff --git a/src/script_interface/ParallelScriptInterface.hpp b/src/script_interface/ParallelScriptInterface.hpp
-index c33e67d..02ad815 100644
---- a/src/script_interface/ParallelScriptInterface.hpp
-+++ b/src/script_interface/ParallelScriptInterface.hpp
-@@ -23,6 +23,7 @@
- #define SCRIPT_INTERFACE_PARALLEL_SCRIPT_INTERFACE_HPP
-
- #include <utility>
-+#include <limits>
-
- #include "MpiCallbacks.hpp"
- #include "ScriptInterface.hpp"
-diff --git a/src/utils/include/utils/NumeratedContainer.hpp b/src/utils/include/utils/NumeratedContainer.hpp
-index 1d99098..1191a79 100644
---- a/src/utils/include/utils/NumeratedContainer.hpp
-+++ b/src/utils/include/utils/NumeratedContainer.hpp
-@@ -24,6 +24,7 @@
- * Keep an enumerated list of T objects, managed by the class.
- */
-
-+#include <cstddef>
- #include <cassert>
- #include <set>
- #include <unordered_map>
-