summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-28 14:03:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-28 14:03:55 +0200
commit87a357c987080a67443e567140482094dd11fef3 (patch)
tree19315fa75143930886e4613616f04a2b31f47f75 /sci-physics
parentmedia-sound/gnac: Remove last-rited pkg (diff)
downloadgentoo-87a357c987080a67443e567140482094dd11fef3.tar.gz
gentoo-87a357c987080a67443e567140482094dd11fef3.tar.bz2
gentoo-87a357c987080a67443e567140482094dd11fef3.zip
sci-physics/hoomd-blue: Remove last-rited pkg
Closes: https://bugs.gentoo.org/624688
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/hoomd-blue/Manifest2
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-2.0.2.ebuild69
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-9999.ebuild69
-rw-r--r--sci-physics/hoomd-blue/metadata.xml18
4 files changed, 0 insertions, 158 deletions
diff --git a/sci-physics/hoomd-blue/Manifest b/sci-physics/hoomd-blue/Manifest
deleted file mode 100644
index 22a73244f0a6..000000000000
--- a/sci-physics/hoomd-blue/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST hoomd-blue-2.0.2.tar.bz2 2942198 BLAKE2B 5a2f964c002fd30d89757720fc9cddf733bbeaf125f7cdbab7b9c1a421e65575936fda903d3912a315433fb530148d7cddcb5830f87d9a81acdc1ba1dbf82ea2 SHA512 6480639bc1b8d0534c220c7512f742a6f9eba76ad25991153735cc7f4ff88345332be4c215abd94de85249e79e85a6970be1a74a96350d4693a2c1291fbbf689
-DIST libgetar-0.5.0.tar.bz2 217067 BLAKE2B 68d7669801d438a509582817c6e7074367a6945ee7c8f8e764dcb97e5a97a6b3394237bed4d07880a3d567b8b23dc1f159597ac51c54d03038beb1592a515952 SHA512 a27de8f7c976e5578142319684de15afca47c24953f590b34cad4ef88c3778aa47aa5eb9a1f83b1473aa49f4394e45dfaa4a8b5107264fa93101dea78ec5fa6b
diff --git a/sci-physics/hoomd-blue/hoomd-blue-2.0.2.ebuild b/sci-physics/hoomd-blue/hoomd-blue-2.0.2.ebuild
deleted file mode 100644
index 4eeb2d729682..000000000000
--- a/sci-physics/hoomd-blue/hoomd-blue-2.0.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils cuda python-r1
-
-DESCRIPTION="a general-purpose particle simulation toolkit"
-HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
-EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
- inherit git-r3
-else
- inherit vcs-snapshot
- GETTAR_VER=0.5.0
- SRC_URI="https://bitbucket.org/glotzer/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2
- https://bitbucket.org/glotzer/libgetar/get/v${GETTAR_VER}.tar.bz2 -> libgetar-${GETTAR_VER}.tar.bz2"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="hoomd-blue"
-SLOT="0"
-IUSE="cuda test mpi"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- mpi? ( virtual/mpi )
- cuda? ( dev-util/nvidia-cuda-sdk )
- dev-libs/boost:=[threads,python,mpi,${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- [[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
-}
-
-src_configure() {
- src_configure_internal() {
- local mycmakeargs=(
- -DENABLE_MPI=$(usex mpi)
- -DENABLE_CUDA=$(usex cuda)
- -DBUILD_TESTING=$(usex test)
- -DUPDATE_SUBMODULES=OFF
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
- )
- cmake-utils_src_configure
- }
- python_foreach_impl src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
-}
diff --git a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
deleted file mode 100644
index 4eeb2d729682..000000000000
--- a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils cuda python-r1
-
-DESCRIPTION="a general-purpose particle simulation toolkit"
-HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
-EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
- inherit git-r3
-else
- inherit vcs-snapshot
- GETTAR_VER=0.5.0
- SRC_URI="https://bitbucket.org/glotzer/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2
- https://bitbucket.org/glotzer/libgetar/get/v${GETTAR_VER}.tar.bz2 -> libgetar-${GETTAR_VER}.tar.bz2"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="hoomd-blue"
-SLOT="0"
-IUSE="cuda test mpi"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- mpi? ( virtual/mpi )
- cuda? ( dev-util/nvidia-cuda-sdk )
- dev-libs/boost:=[threads,python,mpi,${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- [[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
-}
-
-src_configure() {
- src_configure_internal() {
- local mycmakeargs=(
- -DENABLE_MPI=$(usex mpi)
- -DENABLE_CUDA=$(usex cuda)
- -DBUILD_TESTING=$(usex test)
- -DUPDATE_SUBMODULES=OFF
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
- )
- cmake-utils_src_configure
- }
- python_foreach_impl src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
-}
diff --git a/sci-physics/hoomd-blue/metadata.xml b/sci-physics/hoomd-blue/metadata.xml
deleted file mode 100644
index 1b92a0a45128..000000000000
--- a/sci-physics/hoomd-blue/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
- <use>
- <flag name="cuda">Enable cuda non-bonded kernels</flag>
- </use>
- <upstream>
- <remote-id type="bitbucket">glotzer/hoomd-blue</remote-id>
- </upstream>
-</pkgmetadata>