summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-03-10 21:05:58 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-10 21:05:58 +0100
commit88701cd3afc40fbba15cffe5e724547eb3e886ba (patch)
treec99c5d97f9f5b1acbbc862b146a8784980937cc7 /sci-physics
parentsci-physics/clhep: reorder variables reported by pkgcheck (diff)
downloadgentoo-88701cd3afc40fbba15cffe5e724547eb3e886ba.tar.gz
gentoo-88701cd3afc40fbba15cffe5e724547eb3e886ba.tar.bz2
gentoo-88701cd3afc40fbba15cffe5e724547eb3e886ba.zip
sci-physics/vgm: drop 5.0-r1, 5.1-r1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/vgm/Manifest2
-rw-r--r--sci-physics/vgm/vgm-5.0-r1.ebuild86
-rw-r--r--sci-physics/vgm/vgm-5.1-r1.ebuild81
3 files changed, 0 insertions, 169 deletions
diff --git a/sci-physics/vgm/Manifest b/sci-physics/vgm/Manifest
index ccc7ee0a8616..72b367706d35 100644
--- a/sci-physics/vgm/Manifest
+++ b/sci-physics/vgm/Manifest
@@ -1,3 +1 @@
-DIST vgm-5.0.tar.gz 3862583 BLAKE2B 7a1643b329f6f6b019e1b68ce691ed45a32d343925c59451d6e218469606a7a352334d4f1e330873fa1cbc4e1182b4557dc396f52ce7d35e26df81e79121cd60 SHA512 771c2e013c052ea1785fb79ba317b48482428ddf703e263eaf1c9840fbae66dd280d73aee99de30e1c3d70e46a5eb63affc92dfc5ba19298e2d4487b9e302588
-DIST vgm-5.1.tar.gz 3871449 BLAKE2B 19dc9337700edaa854a69b435e6e3012d12762fcc6fe2f3f1799ed11709a04c1b2e6b011ba2de89b251af6bb3471d6969037f4572e51bc21ae1de6cfcb2a3e6f SHA512 ac45c031d3e72d171a1d5048aa2d9e1330574a62cb80caa82a2875dfea4d52a314a7c52d4da99b387f6aeb4ce62842776216447082f8d594182210d34bf567ac
DIST vgm-5.2.tar.gz 3963607 BLAKE2B 6b82f0ac8fa345e4a736d38c2e961f04836c943445fa2dbe52e48dcc378826a4aa7e1ea1af74ae097288121e52549d599e434da30bfd2b46c35b177ef42dae14 SHA512 f141215bf67684d41acb3ae3551e0c8b643033fca841d924030eedc18136e94d75efd8940b43eaca2640470c78331fff36957173e98c7f8a1cccc6325abbf870
diff --git a/sci-physics/vgm/vgm-5.0-r1.ebuild b/sci-physics/vgm/vgm-5.0-r1.ebuild
deleted file mode 100644
index 6edd821b53dc..000000000000
--- a/sci-physics/vgm/vgm-5.0-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
-else
- MY_PV=$(ver_rs 1- -)
- SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
-HOMEPAGE="https://github.com/vmc-project/vgm/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc examples +geant4 +root test"
-
-# upper version bound for Geant, see https://github.com/vmc-project/vgm/issues/10
-RDEPEND="
- sci-physics/clhep:=
- geant4? (
- >=sci-physics/geant-4.11
- <sci-physics/geant-4.11.1
- )
- root? ( sci-physics/root:= )"
-DEPEND="${RDEPEND}
- doc? ( app-text/doxygen[dot] )
- test? (
- >=sci-physics/geant-4.11[gdml]
- sci-physics/geant4_vmc[g4root]
- )"
-RESTRICT="
- !geant4? ( test )
- !root? ( test )
- !test? ( test )
- !examples? ( test )"
-
-DOCS=(
- doc/README
- doc/VGMhistory.txt
- doc/todo.txt
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCLHEP_DIR="${EPREFIX}/usr"
- -DWITH_EXAMPLES="$(usex examples)"
- -DINSTALL_EXAMPLES="$(usex examples)"
- -DWITH_GEANT4="$(usex geant4)"
- -DWITH_ROOT="$(usex root)"
- -DWITH_TEST="$(usex test)"
- )
- if use test && use root && use geant4; then
- mycmakeargs+=( -DWITH_G4ROOT=yes )
- else
- mycmakeargs+=( -DWITH_G4ROOT=no )
- fi
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- doxygen packages/Doxyfile || die
- fi
-}
-
-src_test() {
- cd "${BUILD_DIR}"/test || die
- # See upstream issue: https://github.com/vmc-project/vgm/issues/5
- sed -i 's/ ScaledSolids / /' test3_suite.sh || die
- PATH="${BUILD_DIR}"/test:${PATH} ./test_suite.sh || die
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=( doc/html/. )
- einstalldocs
-}
diff --git a/sci-physics/vgm/vgm-5.1-r1.ebuild b/sci-physics/vgm/vgm-5.1-r1.ebuild
deleted file mode 100644
index 16a49e17a6e6..000000000000
--- a/sci-physics/vgm/vgm-5.1-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
-else
- MY_PV=$(ver_rs 1- -)
- SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
-HOMEPAGE="https://github.com/vmc-project/vgm/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc examples +geant4 +root test"
-
-RDEPEND="
- sci-physics/clhep:=
- geant4? ( >=sci-physics/geant-4.11:= )
- root? ( sci-physics/root:= )"
-DEPEND="${RDEPEND}
- doc? ( app-text/doxygen[dot] )
- test? (
- >=sci-physics/geant-4.11:=[gdml]
- sci-physics/geant4_vmc[g4root]
- )"
-RESTRICT="
- !geant4? ( test )
- !root? ( test )
- !test? ( test )
- !examples? ( test )"
-
-DOCS=(
- doc/README
- doc/VGMhistory.txt
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCLHEP_DIR="${EPREFIX}/usr"
- -DWITH_EXAMPLES="$(usex examples)"
- -DINSTALL_EXAMPLES="$(usex examples)"
- -DWITH_GEANT4="$(usex geant4)"
- -DWITH_ROOT="$(usex root)"
- -DWITH_TEST="$(usex test)"
- )
- if use test && use root && use geant4; then
- mycmakeargs+=( -DWITH_G4ROOT=yes )
- else
- mycmakeargs+=( -DWITH_G4ROOT=no )
- fi
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- doxygen packages/Doxyfile || die
- fi
-}
-
-src_test() {
- cd "${BUILD_DIR}"/test || die
- # See upstream issue: https://github.com/vmc-project/vgm/issues/5
- sed -i 's/ ScaledSolids / /' test3_suite.sh || die
- PATH="${BUILD_DIR}"/test:${PATH} ./test_suite.sh || die
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=( doc/html/. )
- einstalldocs
-}