summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2020-08-23 15:10:35 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-23 15:10:35 +0200
commit8ed83f1faba38e8fdaa3b8261bbba964c7a5c336 (patch)
tree12cbcb0b24b990c36edceb6b5262b4b259a393ab /sci-physics
parentsci-physics/bullet: self-assigned as proxy maintainer (diff)
downloadgentoo-8ed83f1faba38e8fdaa3b8261bbba964c7a5c336.tar.gz
gentoo-8ed83f1faba38e8fdaa3b8261bbba964c7a5c336.tar.bz2
gentoo-8ed83f1faba38e8fdaa3b8261bbba964c7a5c336.zip
sci-physics/bullet: migrate to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://github.com/gentoo/gentoo/pull/17226 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/bullet-2.86.ebuild29
-rw-r--r--sci-physics/bullet/files/bullet-2.85-soversion.patch25
2 files changed, 21 insertions, 33 deletions
diff --git a/sci-physics/bullet/bullet-2.86.ebuild b/sci-physics/bullet/bullet-2.86.ebuild
index b0238f5c9d49..f983c772bb62 100644
--- a/sci-physics/bullet/bullet-2.86.ebuild
+++ b/sci-physics/bullet/bullet-2.86.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Continuous Collision Detection and Physics Library"
HOMEPAGE="http://www.bulletphysics.com/"
@@ -17,10 +17,8 @@ IUSE="+bullet3 doc double-precision examples extras test"
RDEPEND="
virtual/opengl
media-libs/freeglut"
-
-DEPEND="
- ${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
@@ -32,7 +30,7 @@ RESTRICT="test"
S="${WORKDIR}/${PN}3-${PV}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# allow to generate docs
sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
@@ -40,7 +38,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-DBUILD_CPU_DEMOS=OFF
-DBUILD_OPENGL3_DEMOS=OFF
-DBUILD_BULLET2_DEMOS=OFF
@@ -52,21 +49,21 @@ src_configure() {
-DUSE_DOUBLE_PRECISION=$(usex double-precision)
-DBUILD_UNIT_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc; then
doxygen || die
HTML_DOCS+=( html/. )
DOCS+=( docs/*.pdf )
fi
-}
-src_install() {
- cmake-utils_src_install
- use examples && DOCS+=( examples )
- einstalldocs
+ if use examples; then
+ # throws QA warnings
+ rm examples/ThirdPartyLibs/openvr/*/linux64/libopenvr_api.so || die
+ DOCS+=( examples )
+ fi
}
diff --git a/sci-physics/bullet/files/bullet-2.85-soversion.patch b/sci-physics/bullet/files/bullet-2.85-soversion.patch
index 74cfe4e8f8aa..342569355d87 100644
--- a/sci-physics/bullet/files/bullet-2.85-soversion.patch
+++ b/sci-physics/bullet/files/bullet-2.85-soversion.patch
@@ -1,31 +1,22 @@
- Extras/Serialize/BulletFileLoader/CMakeLists.txt | 2 ++
- .../Serialize/BulletWorldImporter/CMakeLists.txt | 2 ++
- Extras/glui/CMakeLists.txt | 2 ++
- 3 files changed, 6 insertions(+), 0 deletions(-)
-
-diff --git a/Extras/Serialize/BulletFileLoader/CMakeLists.txt b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
-index 486cfdc..f1e0884 100644
--- a/Extras/Serialize/BulletFileLoader/CMakeLists.txt
+++ b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
-@@ -16,6 +16,8 @@ btBulletFile.cpp
- btBulletFile.h
- )
+@@ -20,6 +20,8 @@
+
+ ADD_LIBRARY(BulletFileLoader ${BulletFileLoader_SRCS} ${BulletFileLoader_HDRS})
+SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES VERSION ${BULLET_VERSION})
+SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES SOVERSION ${BULLET_VERSION})
IF (BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(BulletFileLoader LinearMath)
+ TARGET_LINK_LIBRARIES(BulletFileLoader LinearMath)
ENDIF (BUILD_SHARED_LIBS)
-diff --git a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
-index e620315..e04e8e9 100644
--- a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
+++ b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
-@@ -9,6 +9,8 @@ btBulletWorldImporter.cpp
- btBulletWorldImporter.h
- )
+@@ -14,6 +14,8 @@
+ SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES VERSION ${BULLET_VERSION})
+ SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES SOVERSION ${BULLET_VERSION})
+SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES VERSION ${BULLET_VERSION})
+SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES SOVERSION ${BULLET_VERSION})
IF (BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(BulletWorldImporter BulletDynamics BulletCollision BulletFileLoader LinearMath)
+ TARGET_LINK_LIBRARIES(BulletWorldImporter BulletDynamics BulletCollision BulletFileLoader LinearMath)
ENDIF (BUILD_SHARED_LIBS)