summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 20:11:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:38 +0100
commit931af7747167c447b23b0e83f2f377b010a80fc6 (patch)
tree37fb26dfaa2f62f37f616e02f3a2b6262736e4c5 /sci-physics
parentsci-physics/rivet: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-931af7747167c447b23b0e83f2f377b010a80fc6.tar.gz
gentoo-931af7747167c447b23b0e83f2f377b010a80fc6.tar.bz2
gentoo-931af7747167c447b23b0e83f2f377b010a80fc6.zip
sci-physics/yoda: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/yoda-1.6.5.ebuild10
-rw-r--r--sci-physics/yoda/yoda-1.7.0-r1.ebuild (renamed from sci-physics/yoda/yoda-1.7.0.ebuild)10
2 files changed, 14 insertions, 6 deletions
diff --git a/sci-physics/yoda/yoda-1.6.5.ebuild b/sci-physics/yoda/yoda-1.6.5.ebuild
index 00d3f8949c26..82bf586a70b0 100644
--- a/sci-physics/yoda/yoda-1.6.5.ebuild
+++ b/sci-physics/yoda/yoda-1.6.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,9 +20,13 @@ IUSE="python root static-libs"
RDEPEND="
dev-libs/boost:=
python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+ root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
DEPEND="${RDEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/sci-physics/yoda/yoda-1.7.0.ebuild b/sci-physics/yoda/yoda-1.7.0-r1.ebuild
index 9f53d934f26e..a29234715ba0 100644
--- a/sci-physics/yoda/yoda-1.7.0.ebuild
+++ b/sci-physics/yoda/yoda-1.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,9 +19,13 @@ IUSE="python root static-libs"
RDEPEND="
python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+ root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
DEPEND="${RDEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"