summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-08-16 09:21:58 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-08-16 09:22:19 -0600
commit93533be3232554ddc1b0546ea1f1bde62c348bc7 (patch)
tree951dded48529a3751b39b1afbc66d98cf326a1ad /sci-physics
parentx11-terms/roxterm: x86 stable wrt bug #737422 (diff)
downloadgentoo-93533be3232554ddc1b0546ea1f1bde62c348bc7.tar.gz
gentoo-93533be3232554ddc1b0546ea1f1bde62c348bc7.tar.bz2
gentoo-93533be3232554ddc1b0546ea1f1bde62c348bc7.zip
sci-physics/espresso: version bump
Closes: https://bugs.gentoo.org/737416 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/Manifest1
-rw-r--r--sci-physics/espresso/espresso-4.1.3.ebuild117
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild31
-rw-r--r--sci-physics/espresso/metadata.xml4
4 files changed, 134 insertions, 19 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
index 2b8aa0ed6e97..a4941b7d1888 100644
--- a/sci-physics/espresso/Manifest
+++ b/sci-physics/espresso/Manifest
@@ -1,2 +1,3 @@
DIST espresso-4.0.0.tar.gz 25767191 BLAKE2B 995678496fe35b957c4a5775f79f6656efbb5f717a43e90f8c5fa406aba7847cd34b00db3f313e5a7b0a11a96b521e8182bdd58129ad68ea4881c9496e3977e5 SHA512 53eb311e8bb7db5aed32dcd3adfd5e1c63e6ae42a22cea41844edfa857fee03ffd717c0739dd46a6cdf8ca7a4c4b0952a036b208fccc4e61de3f383910e7d019
DIST espresso-4.0_pre20170228.tar.gz 23621395 BLAKE2B 6381e519c59986e50ff74fb3d81cd157f4761e1c46ea96b384487fd079b9c6f881dfa70df8f62e275fdd57bda6a4c714002630cebb02c232029186c3adbb692f SHA512 7d35648d447af3282a76d9d68cfe681734ec18794a38b09e0ae9233f63b62450c643643bcec999ea9c7d4ba070d4fc6f8dc64db8145f536ae017a67ff2d0e0e2
+DIST espresso-4.1.3.tar.gz 16947336 BLAKE2B 14d3513eda87f62a8473a0cac0c273b3590bf78ed48b96e76d10c106713f7bbd7d37de951bd3d9210062b34c02bd83a68f3aaf1ca8215ed1dcde590e4e99b113 SHA512 1fe82683eddb7bfd9bae6e446b0f42a50087d755995963905cd419473ad17b204f20049d0cf4af9264898dd6fee36f02744b38fa45cd0e33086374cf2aebd934
diff --git a/sci-physics/espresso/espresso-4.1.3.ebuild b/sci-physics/espresso/espresso-4.1.3.ebuild
new file mode 100644
index 000000000000..ef5f6578edce
--- /dev/null
+++ b/sci-physics/espresso/espresso-4.1.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
+ EGIT_BRANCH="python"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}md/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cuda doc examples +fftw +hdf5 test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/boost:=[mpi]
+ hdf5? ( sci-libs/hdf5:=[mpi] )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_CUDA=$(usex cuda)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DWITH_TESTS=$(usex test)
+ -DINSTALL_PYPRESSO=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
+ -DWITH_HDF5=$(usex hdf5)
+ -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
+ -DCMAKE_SKIP_RPATH=YES
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doxygen
+ [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
+}
+
+src_install() {
+ local i docdir="${S}"
+
+ cmake_src_install
+
+ insinto /usr/share/${PN}/
+ doins "${BUILD_DIR}/myconfig-sample.hpp"
+
+ save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
+
+ if use doc; then
+ [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
+ newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ dodoc -r "${BUILD_DIR}/doc/doxygen/html"
+ fi
+
+ if use examples; then
+ insinto "/usr/share/${PN}/examples/python"
+ doins -r samples/${i}/.
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.hpp"
+ echo
+}
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index fcc6fbc9926e..ef5f6578edce 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils python-single-r1 savedconfig
+inherit cmake python-single-r1 savedconfig
DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
HOMEPAGE="http://espressomd.org"
@@ -48,9 +48,11 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README ChangeLog )
+S="${WORKDIR}/${PN}"
+
src_prepare() {
use cuda && cuda_src_prepare
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -63,35 +65,34 @@ src_configure() {
-DWITH_HDF5=$(usex hdf5)
-DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
-DCMAKE_SKIP_RPATH=YES
- -DLIBDIR=$(get_libdir)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake-utils_src_make ug dg tutorials
+ cmake_src_compile
+ use doc && cmake_build doxygen
+ [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
}
src_install() {
local i docdir="${S}"
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}/
- doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
+ doins "${BUILD_DIR}/myconfig-sample.hpp"
- save_config ${CMAKE_BUILD_DIR}/src/core/myconfig-final.hpp
+ save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${CMAKE_BUILD_DIR}"
+ [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
newdoc "${i}" "tutorial_${i##*/}"
done
- dodoc -r ${CMAKE_BUILD_DIR}/doc/doxygen/html
+ dodoc -r "${BUILD_DIR}/doc/doxygen/html"
fi
if use examples; then
diff --git a/sci-physics/espresso/metadata.xml b/sci-physics/espresso/metadata.xml
index 87ef8dd6f089..37615e72f9b7 100644
--- a/sci-physics/espresso/metadata.xml
+++ b/sci-physics/espresso/metadata.xml
@@ -1,10 +1,6 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
<maintainer type="project">
<email>sci-physics@gentoo.org</email>
<name>Gentoo Physics Project</name>