summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/fig2sxd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/fig2sxd/files')
-rw-r--r--sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch12
-rw-r--r--sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch9
2 files changed, 21 insertions, 0 deletions
diff --git a/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch b/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch
new file mode 100644
index 000000000000..a9bd521d3196
--- /dev/null
+++ b/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Naur fig2sxd-0.20/Makefile fig2sxd-0.20.new/Makefile
+--- fig2sxd-0.20/Makefile 2008-05-16 18:47:34.000000000 -0400
++++ fig2sxd-0.20.new/Makefile 2009-08-31 22:14:38.000000000 -0400
+@@ -51,7 +51,7 @@
+ LIBS = -lz
+
+ $(TARGET1): $(OBJECTS1)
+- $(CXX) -o $@ $^ $(LIBS)
++ $(CXX) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(OBJECTS1): %.o: $(SRCDIR)%.cpp $(DEPEND)%.dep
+ $(CXX) $(CXXFLAGS) -o $@ -c $<
diff --git a/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch b/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch
new file mode 100644
index 000000000000..d9e76b8c9780
--- /dev/null
+++ b/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch
@@ -0,0 +1,9 @@
+diff -Naur fig2sxd-0.20/Makefile fig2sxd-0.20.new/Makefile
+--- fig2sxd-0.20/Makefile 2008-05-16 18:47:34.000000000 -0400
++++ fig2sxd-0.20.new/Makefile 2009-08-31 22:22:07.000000000 -0400
+@@ -75,4 +75,4 @@
+ tar czf `date +"../fig2sxd-%Y-%m-%d-%H-%M.tar.gz"` -C $(SRCDIR)../ \
+ $(ARCHFILES)
+
+-.PHONY: all clean
++.PHONY: all clean check