summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-03-15 09:28:46 +0100
committerDavid Seifert <soap@gentoo.org>2016-03-15 09:29:15 +0100
commit5ab7a2ef03d55a4fec4409b301cc11b88f9c1b61 (patch)
tree32b9e2d2843b9983d9c360dcc7a56682037635fb /sci-visualization/ggobi
parentapp-emulation/xen-tools: x86 stable wrt bug #574012 (diff)
downloadgentoo-5ab7a2ef03d55a4fec4409b301cc11b88f9c1b61.tar.gz
gentoo-5ab7a2ef03d55a4fec4409b301cc11b88f9c1b61.tar.bz2
gentoo-5ab7a2ef03d55a4fec4409b301cc11b88f9c1b61.zip
sci-visualization/ggobi: Fix -Werror=format-security errors
Gentoo-Bug: 577430 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-visualization/ggobi')
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch36
-rw-r--r--sci-visualization/ggobi/ggobi-2.1.11.ebuild5
2 files changed, 39 insertions, 2 deletions
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch b/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch
new file mode 100644
index 000000000000..960d940a7908
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.11-Wformat-security.patch
@@ -0,0 +1,36 @@
+Fix -Wformat -Werror=format-security errors caused by wrong fprintf calls
+See also: https://bugs.gentoo.org/show_bug.cgi?id=577430
+* utils_ui.c: In function ‘quick_message’:
+* utils_ui.c:192:29: error: format not a string literal and no format arguments [-Werror=format-security]
+* message);
+
+--- ggobi-2.1.11/src/utils_ui.c
++++ ggobi-2.1.11/src/utils_ui.c
+@@ -189,7 +189,7 @@
+
+ dialog =
+ gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_INFO, GTK_BUTTONS_OK,
+- message);
++ "%s", message);
+
+ if (modal)
+ gtk_window_set_modal (GTK_WINDOW (dialog), true);
+--- ggobi-2.1.11/src/write_xml.c
++++ ggobi-2.1.11/src/write_xml.c
+@@ -37,14 +37,14 @@
+ write_xml_string(FILE *f, gchar *str)
+ {
+ gchar *fmtstr = g_markup_printf_escaped("%s", str);
+- fprintf(f, fmtstr);
++ fprintf(f, "%s", fmtstr);
+ g_free(fmtstr);
+ }
+ static void
+ write_xml_string_fmt(FILE *f, gchar *fmt, gchar *str)
+ {
+ gchar *fmtstr = g_markup_printf_escaped(fmt, str);
+- fprintf(f, fmtstr);
++ fprintf(f, "%s", fmtstr);
+ g_free(fmtstr);
+ }
+
diff --git a/sci-visualization/ggobi/ggobi-2.1.11.ebuild b/sci-visualization/ggobi/ggobi-2.1.11.ebuild
index 7f25d29c3552..ef6aea6e23bd 100644
--- a/sci-visualization/ggobi/ggobi-2.1.11.ebuild
+++ b/sci-visualization/ggobi/ggobi-2.1.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-2.1.8-plugindir.patch \
"${FILESDIR}"/${PN}-2.1.9-as-needed.patch \
- "${FILESDIR}"/${PN}-2.1.10-desktop.patch
+ "${FILESDIR}"/${PN}-2.1.10-desktop.patch \
+ "${FILESDIR}"/${PN}-2.1.11-Wformat-security.patch
# need the ${S} for recursivity lookup
AT_M4DIR="${S}"/m4 eautoreconf
}