summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/pyxplot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/pyxplot')
-rw-r--r--sci-visualization/pyxplot/Manifest2
-rw-r--r--sci-visualization/pyxplot/files/pyxplot-0.8.3-as-needed.patch56
-rw-r--r--sci-visualization/pyxplot/metadata.xml14
-rw-r--r--sci-visualization/pyxplot/pyxplot-0.7.1.ebuild46
-rw-r--r--sci-visualization/pyxplot/pyxplot-0.9.2.ebuild40
5 files changed, 158 insertions, 0 deletions
diff --git a/sci-visualization/pyxplot/Manifest b/sci-visualization/pyxplot/Manifest
new file mode 100644
index 000000000000..dd31f92ffc2b
--- /dev/null
+++ b/sci-visualization/pyxplot/Manifest
@@ -0,0 +1,2 @@
+DIST pyxplot_0.7.1.tar.gz 2439857 SHA256 262b4337c1fdb8e54c11eb76415b814243f6dbab28163fd1e208378d860d2a84
+DIST pyxplot_0.9.2.tar.gz 4131841 SHA256 1c592a0bc77caec445a8d72534471c01d66ca1806309e6c983847c2e0b95e689 SHA512 34c43fec36dd579161c7adb9f0bab012c5d3e59c904526f82a70a31685b88a231c300ab4dbdff376b29fdd5698c376d55f7a2f2786d7960c4de7e6e0776fa844 WHIRLPOOL f380489231f01ad81f983bb7fe11fb0323ca3d5dedeb60c84739e122c567e3581bb04962ecf83f21751d49a773d129b2b332b0aed4e9192ec064b5ee14714881
diff --git a/sci-visualization/pyxplot/files/pyxplot-0.8.3-as-needed.patch b/sci-visualization/pyxplot/files/pyxplot-0.8.3-as-needed.patch
new file mode 100644
index 000000000000..bdb1507a888e
--- /dev/null
+++ b/sci-visualization/pyxplot/files/pyxplot-0.8.3-as-needed.patch
@@ -0,0 +1,56 @@
+--- Makefile.skel.orig 2010-09-24 14:54:19.000000000 +0100
++++ Makefile.skel 2010-09-25 20:35:30.000000000 +0100
+@@ -120,17 +120,17 @@
+
+ $(LOCAL_BINDIR)/pyxplot: $(PPL_OBJECTS)
+ mkdir -p $(LOCAL_BINDIR)
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPL_OBJECTS) -o $(LOCAL_BINDIR)/pyxplot
++ $(LINK) $(LDFLAGS) $(PPL_OBJECTS) $(LIBS) -o $(LOCAL_BINDIR)/pyxplot
+
+ $(LOCAL_BINDIR)/debug/pyxplot: $(PPL_OBJECTS_DEBUG)
+ mkdir -p $(LOCAL_BINDIR)/debug
+ echo "The files in this directory are binaries with debugging options enabled: they produce activity logs called 'pyxplot.log'. It should be noted that these binaries can up to ten times slower than non-debugging versions." > $(LOCAL_BINDIR)/debug/README
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPL_OBJECTS_DEBUG) -o $(LOCAL_BINDIR)/debug/pyxplot
++ $(LINK) $(LDFLAGS) $(PPL_OBJECTS_DEBUG) $(LIBS) -o $(LOCAL_BINDIR)/debug/pyxplot
+
+ $(LOCAL_BINDIR)/install/pyxplot: $(PPL_OBJECTS_INSTALL)
+ mkdir -p $(LOCAL_BINDIR)/install
+ echo "The files in this directory are binaries intended to be installed with 'make install'. They should not be used in their present location, as they contain hard-coded links to files which are created by the 'make install' step." > $(LOCAL_BINDIR)/debug/README
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPL_OBJECTS_INSTALL) -o $(LOCAL_BINDIR)/install/pyxplot
++ $(LINK) $(LDFLAGS) $(PPL_OBJECTS_INSTALL) $(LIBS) -o $(LOCAL_BINDIR)/install/pyxplot
+
+ #
+ # Make the pyxplot_watch binaries
+@@ -138,15 +138,15 @@
+
+ $(LOCAL_BINDIR)/pyxplot_watch: $(PPLW_OBJECTS)
+ mkdir -p $(LOCAL_BINDIR)
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPLW_OBJECTS) -o $(LOCAL_BINDIR)/pyxplot_watch
++ $(LINK) $(LDFLAGS) $(PPLW_OBJECTS) $(LIBS) -o $(LOCAL_BINDIR)/pyxplot_watch
+
+ $(LOCAL_BINDIR)/debug/pyxplot_watch: $(PPLW_OBJECTS_DEBUG)
+ mkdir -p $(LOCAL_BINDIR)/debug
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPLW_OBJECTS_DEBUG) -o $(LOCAL_BINDIR)/debug/pyxplot_watch
++ $(LINK) $(LDFLAGS) $(PPLW_OBJECTS_DEBUG) $(LIBS) -o $(LOCAL_BINDIR)/debug/pyxplot_watch
+
+ $(LOCAL_BINDIR)/install/pyxplot_watch: $(PPLW_OBJECTS_INSTALL)
+ mkdir -p $(LOCAL_BINDIR)/install
+- $(LINK) $(LDFLAGS) $(LIBS) $(PPLW_OBJECTS_INSTALL) -o $(LOCAL_BINDIR)/install/pyxplot_watch
++ $(LINK) $(LDFLAGS) $(PPLW_OBJECTS_INSTALL) $(LIBS) -o $(LOCAL_BINDIR)/install/pyxplot_watch
+
+ #
+ # Make fits helper binaries
+@@ -154,11 +154,11 @@
+
+ $(LOCAL_BINDIR)/pyxplot_fitshelper: $(FITSHELP_OBJECTS)
+ mkdir -p $(LOCAL_BINDIR)
+- $(LINK) $(LDFLAGS) $(LINK_FITSIO) $(LIBS) $(FITSHELP_OBJECTS) -o $(LOCAL_BINDIR)/pyxplot_fitshelper
++ $(LINK) $(LDFLAGS) $(FITSHELP_OBJECTS) $(LIBS) $(LINK_FITSIO) -o $(LOCAL_BINDIR)/pyxplot_fitshelper
+
+ $(LOCAL_BINDIR)/install/pyxplot_fitshelper: $(FITSHELP_OBJECTS_INSTALL)
+ mkdir -p $(LOCAL_BINDIR)/install
+- $(LINK) $(LDFLAGS) $(LINK_FITSIO) $(LIBS) $(FITSHELP_OBJECTS_INSTALL) -o $(LOCAL_BINDIR)/install/pyxplot_fitshelper
++ $(LINK) $(LDFLAGS) $(FITSHELP_OBJECTS_INSTALL) $(LIBS) $(LINK_FITSIO) -o $(LOCAL_BINDIR)/install/pyxplot_fitshelper
+
+ #
+ # Make time helper
diff --git a/sci-visualization/pyxplot/metadata.xml b/sci-visualization/pyxplot/metadata.xml
new file mode 100644
index 000000000000..6659594ec46f
--- /dev/null
+++ b/sci-visualization/pyxplot/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ PyXPlot is a command-line graphing package with a simple interface
+ that produces publication-quality output. Its command line interface is very
+ gnuplot oriented and has actually some compatibility. The output
+ is based on LaTeX typesetting environment.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyxplot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
new file mode 100644
index 000000000000..e9a30394830c
--- /dev/null
+++ b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="Gnuplot like graphing program publication-quality figures"
+HOMEPAGE="http://www.pyxplot.org.uk/"
+SRC_URI="http://www.pyxplot.org.uk/src/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ sci-libs/scipy
+ app-text/gv
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:^\(USRDIR=\).*:\1/usr:g" \
+ -e "s:^\(SRCDIR=\).*:\1$(python_get_sitedir)/${PN}:g" \
+ -e 's:^\(MANDIR=\).*:\1${USRDIR}/share/man/man1:g' \
+ -e "s:^\(DOCDIR=\).*:\1\${USRDIR}/share/doc/${PF}:g" \
+ -e '/install:/,$s:${\(SRC\|BIN\|DOC\|MAN\)DIR:${DESTDIR}/${\1DIR:g' \
+ -e "/pyc/d" \
+ -e 's/ex_\*/{ex_,fig}\*/' \
+ Makefile.skel || die "sed Makefile.skel failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS ChangeLog
+}
diff --git a/sci-visualization/pyxplot/pyxplot-0.9.2.ebuild b/sci-visualization/pyxplot/pyxplot-0.9.2.ebuild
new file mode 100644
index 000000000000..82905daaa087
--- /dev/null
+++ b/sci-visualization/pyxplot/pyxplot-0.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Gnuplot like graphing program publication-quality figures"
+HOMEPAGE="http://www.pyxplot.org.uk/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ app-text/gv
+ dev-libs/libxml2:2
+ media-libs/libpng
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0
+ sci-libs/gsl
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/latex-base
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed \
+ -e "s:/usr/local:${EROOT}usr/:" \
+ -e "s:/lib/:/$(get_libdir)/:" \
+ -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i Makefile.skel || die "sed Makefile.skel failed"
+ sed -i -e 's/-ltermcap//' configure || die
+}