summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/quickplot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/quickplot')
-rw-r--r--sci-visualization/quickplot/Manifest2
-rw-r--r--sci-visualization/quickplot/metadata.xml16
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.6.ebuild44
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.8.ebuild44
4 files changed, 106 insertions, 0 deletions
diff --git a/sci-visualization/quickplot/Manifest b/sci-visualization/quickplot/Manifest
new file mode 100644
index 000000000000..e58f25ba309b
--- /dev/null
+++ b/sci-visualization/quickplot/Manifest
@@ -0,0 +1,2 @@
+DIST quickplot-0.10.6.tar.xz 445172 SHA256 6560dcfade541ed183d0609682a64915d66f437bf7268e1f221216b2a453d878 SHA512 10b5277d8d0b8febc3c663256f3912bdd9d879b3038a5fdd3a7adc223419893ee56b825f04b5bee29883f30acb3b6a329d8e314b049fef26d6220192767d4adb WHIRLPOOL d0f2b49db8fb3e74c7f4483a65bf278dd9c196833f341f2ea5d1d5b91bf36b2549e8465d64eed410e7c63a1cd6bef85e49200f102c79dc9d39a0a59be2e26ede
+DIST quickplot-0.10.8.tar.bz2 531610 SHA256 ec3946daf978f9c18537c88c15be9e84f84097ab3bb7b04dae62edad5ba91456 SHA512 e382206ba70849755e4110070a5e6b128bea4502ef623c59aa041ba84ed407e0ad06c62366b3bbcd71f8a76a3e651a04efab61edeb616ab6321c5680b03afa95 WHIRLPOOL 84216eadfe905741c19ce036c621d6386a538bcee939ea7abd3e6bd90e2249f858b51400fbe8d79a0c3ccb93fabd00915012d3443afebac00c71d667ac4faf5f
diff --git a/sci-visualization/quickplot/metadata.xml b/sci-visualization/quickplot/metadata.xml
new file mode 100644
index 000000000000..ccaedd7cfc1b
--- /dev/null
+++ b/sci-visualization/quickplot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Quickplot is a fast interactive 2D plotter with infinite zooming, value
+ picking, pipe input, and unlimited plots displayed. Quickplot is meant for
+ looking at your data quickly and of secondary importance is making static
+ pictures of your data. It's a data viewer, not a plot editor. It reads
+ ASCII text and sound files. It has lots of command line options, making it
+ very shell script friendly.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">quickplot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-visualization/quickplot/quickplot-0.10.6.ebuild b/sci-visualization/quickplot/quickplot-0.10.6.ebuild
new file mode 100644
index 000000000000..eb15ab191f06
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed '/libquickplot_la_LIBADD/s:$: -lm:g' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${ED}"/usr/share/applications/quickplot*.desktop \
+ "${ED}"/usr/share/applications/quickplot.desktop || die
+}
diff --git a/sci-visualization/quickplot/quickplot-0.10.8.ebuild b/sci-visualization/quickplot/quickplot-0.10.8.ebuild
new file mode 100644
index 000000000000..c1b72dec9964
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed '/libquickplot_la_LIBADD/s:$: -lm:g' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${ED}"/usr/share/applications/quickplot*.desktop \
+ "${ED}"/usr/share/applications/quickplot.desktop || die
+}