summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-05-06 17:43:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-05-06 17:43:21 +0700
commitb207d6ece92e4a9e4e929fc515c8567a12873ccc (patch)
tree4ac146a235d20e9ee96328b5b144607fcedb457c /sci-visualization/veusz
parentdev-python/translate-toolkit: Stabilize 3.3.4 ALLARCHES, #788565 (diff)
downloadgentoo-b207d6ece92e4a9e4e929fc515c8567a12873ccc.tar.gz
gentoo-b207d6ece92e4a9e4e929fc515c8567a12873ccc.tar.bz2
gentoo-b207d6ece92e4a9e4e929fc515c8567a12873ccc.zip
sci-visualization/veusz: bump to 3.3.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-visualization/veusz')
-rw-r--r--sci-visualization/veusz/Manifest1
-rw-r--r--sci-visualization/veusz/veusz-3.3.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-visualization/veusz/Manifest b/sci-visualization/veusz/Manifest
index 67ae1eac5d4a..88db9ae4c5b6 100644
--- a/sci-visualization/veusz/Manifest
+++ b/sci-visualization/veusz/Manifest
@@ -1 +1,2 @@
DIST veusz-3.2.tar.gz 2528125 BLAKE2B 614488779d1c0e5d800f2b1c86b82615676b08af46831abd6c55653471b045f0c9d28a8cb7489cbb2391fd5f21ab2d40aa6bff4fc195426f3b07b91f6d4ee8d7 SHA512 01e1a030246a3d6811493968f2f30084b2c465195af166b7bdc4009de4c488350a4fba300acee1959310b318e8dc519f090bfca528491811ca52640c33d048bc
+DIST veusz-3.3.1.tar.gz 3249376 BLAKE2B d3113a4f5f6a2fc3460e73b6b99d6353d6a0745a0d3cc0f276a86cb6fcef369bb74ca34aa205c69e7755dbe6d6fa6dce3ff267ca075f211c8635cab0350233a5 SHA512 a2fa204a33ae0dac98907c3af88b24f322849360e30c05101bbfa6307dc8aa6fdec580f060fc9cd9921f7706db51419efe088f927d22db860419eea4e0f4e84c
diff --git a/sci-visualization/veusz/veusz-3.3.1.ebuild b/sci-visualization/veusz/veusz-3.3.1.ebuild
new file mode 100644
index 000000000000..b16d8a6ce9c6
--- /dev/null
+++ b/sci-visualization/veusz/veusz-3.3.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit desktop distutils-r1 qmake-utils virtualx xdg
+
+DESCRIPTION="Qt scientific plotting package with good Postscript output"
+HOMEPAGE="https://veusz.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus doc hdf5"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[widgets,svg,printsupport,${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ xdg_environment_reset
+}
+
+python_compile() {
+ distutils-r1_python_compile build_ext --qmake-exe=$(qt5_get_bindir)/qmake
+}
+
+python_test() {
+ distutils_install_for_testing
+ VIRTUALX_COMMAND="${EPYTHON}" \
+ VEUSZ_RESOURCE_DIR="${S}" \
+ virtx tests/runselftest.py
+}
+
+python_install() {
+ distutils-r1_python_install
+ # symlink the license, bug #341653
+ rm "${D}/$(python_get_sitedir)"/${PN}/{COPYING,AUTHORS,ChangeLog} || die
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+ cat >> "${D}/$(python_get_sitedir)"/${PN}/COPYING <<- EOF
+ Please visit
+
+ https://www.gnu.org/licenses/gpl-2.0.html
+
+ for the full license text.
+ EOF
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc Documents/manual/pdf/${PN}.pdf
+ docinto html
+ dodoc -r Documents/manual/html
+ fi
+
+ doicon icons/veusz.png
+ domenu "${FILESDIR}"/veusz.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/veusz.xml
+}