summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-13 13:51:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-13 13:52:16 +0200
commit0db95041b8c4308c98ccef49af0faf21e59477b8 (patch)
tree3e4b84b01e40ad259a5047b799df3e71fac3c42b /sci-visualization
parentsys-kernel/linux-firmware: drop 20210518 (diff)
downloadgentoo-0db95041b8c4308c98ccef49af0faf21e59477b8.tar.gz
gentoo-0db95041b8c4308c98ccef49af0faf21e59477b8.tar.bz2
gentoo-0db95041b8c4308c98ccef49af0faf21e59477b8.zip
sci-visualization/gwyddion: add 2.61
Bug: https://bugs.gentoo.org/851663 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.61.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index 17b49326cbea..707291aef688 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1,2 +1,3 @@
DIST gwyddion-2.56.tar.xz 4645620 BLAKE2B f4f2ce2bf119a24c3e1919b14db409a81ad286ef2242918f356d2b4c56b498f41cbafa03a136eac5d87b4905529e06982694f19bdf30933454e94d34526962c3 SHA512 cf4a40367ea5b0a671c5df70123ef93f6aecc25322af7eb05e4f32d40e54d9b0d48ddd1df9f2589c468eb511ada3f3ef409603c1513de33ba2482078a9415eae
DIST gwyddion-2.60.tar.xz 4973404 BLAKE2B 6ded40f34bfcd70db2e897abc1f07b070aca78e08c90661ee4fe281d19f16337ca81b5a4e2adaeb29e1870e8194eb77976910a54248842c8474864065d64defd SHA512 e568df77ef580aaedfcdd1f746a78f3ca93676a07a331fc6e70f997780bb403d1c3967aa93440c7fa1f010bd01f5376700c869a38dacaf1f98b075c4c950cf54
+DIST gwyddion-2.61.tar.xz 4982092 BLAKE2B e4949558c52d2a6e97415b65e6816061c117868bdd2f39b341c3f740500f71dd38500323a389058b65f9c30feb9d5fd1e93bc29881b464cdb66981639fe280ed SHA512 c2fff49d52e4c439bf96e68be3534948c1fd48ade9b1e59e2d2d7d607170b5e7ce09e9cde3873ecca526de1561b028f39785dc363186f9f3d4ef0d259d313675
diff --git a/sci-visualization/gwyddion/gwyddion-2.61.ebuild b/sci-visualization/gwyddion/gwyddion-2.61.ebuild
new file mode 100644
index 000000000000..7a324f0066a3
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.61.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ dev-libs/libzip
+ media-libs/libpng:0=
+ >=sci-libs/fftw-3.1:3.0=[openmp?]
+ virtual/libiconv
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libXmu
+ x11-libs/pango
+ bzip2? ( app-arch/bzip2 )
+ fits? ( sci-libs/cfitsio[bzip2?] )
+ jansson? ( dev-libs/jansson )
+ hdf5? ( sci-libs/hdf5[zlib?] )
+ openexr? ( media-libs/openexr:= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-ruby/narray )
+ unique? ( dev-libs/libunique:3 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.60-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# There are python bindings (--enable-pygwy) but they are py2 only
+# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
+src_configure() {
+ # hack for bug 741840
+ use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
+
+ econf \
+ --disable-rpath \
+ --without-kde4-thumbnailer \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openmp) \
+ $(use_enable nls) \
+ --disable-pygwy \
+ --without-python \
+ $(use_with bzip2) \
+ $(use_with fits cfitsio) \
+ $(use_with hdf5) \
+ $(use_with jansson) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with openexr exr) \
+ --without-gl \
+ $(use_with sourceview gtksourceview) \
+ $(use_with unique) \
+ $(use_with xml libxml2) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ --with-zip=libzip
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}