summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-14 15:17:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-01-15 22:59:51 +0000
commit24218dbfd47b2fe7ca0bee5396aebd44b4db0931 (patch)
tree18a617ebc8e4c553fe03b73afc4db910eaf5cd68 /sci-visualization
parentsci-libs/mpir: Backport patch for newer sed (diff)
downloadgentoo-24218dbfd47b2fe7ca0bee5396aebd44b4db0931.tar.gz
gentoo-24218dbfd47b2fe7ca0bee5396aebd44b4db0931.tar.bz2
gentoo-24218dbfd47b2fe7ca0bee5396aebd44b4db0931.zip
sci-visualization/gcalc: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3471
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gcalc/gcalc-3.1_rc1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-visualization/gcalc/gcalc-3.1_rc1-r1.ebuild b/sci-visualization/gcalc/gcalc-3.1_rc1-r1.ebuild
new file mode 100644
index 000000000000..6aaed93792f5
--- /dev/null
+++ b/sci-visualization/gcalc/gcalc-3.1_rc1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+MY_P="GCalc-${PV/_/-}"
+DESCRIPTION="Java Mathematical Graphing System"
+HOMEPAGE="http://gcalc.net/"
+SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+SLOT="0"
+
+RDEPEND=">=virtual/jre-1.7
+ !!sci-mathematics/gcalc"
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ java-pkg_clean
+ default
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar src ! -name "*.html"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc
+
+ newicon src/resources/gicon.png ${PN}.png
+ make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
+}