summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-06-26 12:08:04 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-06-26 12:08:04 +0200
commit34f0388c597e192a1aed9891e6333a46b82ffdf2 (patch)
tree459015a0911828f0cfe0a3c63bfaa3f547903fc8 /sci-visualization
parentsci-visualization/dash: fix werkzeug 2.1.0 import (diff)
downloadgentoo-34f0388c597e192a1aed9891e6333a46b82ffdf2.tar.gz
gentoo-34f0388c597e192a1aed9891e6333a46b82ffdf2.tar.bz2
gentoo-34f0388c597e192a1aed9891e6333a46b82ffdf2.zip
sci-visualization/dash: drop old versions
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/dash/Manifest1
-rw-r--r--sci-visualization/dash/dash-1.20.0-r1.ebuild50
-rw-r--r--sci-visualization/dash/dash-1.21.0.ebuild34
3 files changed, 0 insertions, 85 deletions
diff --git a/sci-visualization/dash/Manifest b/sci-visualization/dash/Manifest
index d5c9e74b0d3e..2082553ce605 100644
--- a/sci-visualization/dash/Manifest
+++ b/sci-visualization/dash/Manifest
@@ -1,2 +1 @@
-DIST dash-1.20.0.tar.gz 1786368 BLAKE2B 2826336f72b9bea80be6ef77df49109b7b68ed93678b606c998a1906907551551a3228e1140d20c6e1b5bf5e53fb9cebd0c0a4d7ab5cc1a590e47ef351558a40 SHA512 670cf593068370c70f1db25c70c7a76ce98c696efbff1146cc90f90a99b8b48bf80cf47688504d173ef253ccb9f1170c2067b3af9414eacb226f7ef25149ffff
DIST dash-1.21.0.tar.gz 1753608 BLAKE2B 07530da9e39065e80f653f97eda5ae8840a05cbc90969640910e1788daea8c5227841fd7de74b90bbb763e3c4b027442eb9e35f52d8ea57a0e8bae4dcab87ce0 SHA512 8254a918f60de9dc329af53f8ff15841be39b130c56c6c6037a2fe4d699fa71f565d7cb0a14d1405f0a1d32cfe886e1531558158596ea1a2b69fd7c62af5a8ce
diff --git a/sci-visualization/dash/dash-1.20.0-r1.ebuild b/sci-visualization/dash/dash-1.20.0-r1.ebuild
deleted file mode 100644
index 0b2685f17351..000000000000
--- a/sci-visualization/dash/dash-1.20.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python framework for building ML & data science web apps"
-HOMEPAGE="https://github.com/plotly/dash"
-SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/future[${PYTHON_USEDEP}]
- sci-visualization/dash-table[${PYTHON_USEDEP}]
- sci-visualization/dash-html-components[${PYTHON_USEDEP}]
- sci-visualization/dash-core-components[${PYTHON_USEDEP}]
- dev-python/plotly[${PYTHON_USEDEP}]
- dev-python/flask-compress[${PYTHON_USEDEP}]"
-BDEPEND=""
-
-src_prepare() {
- distutils-r1_src_prepare
- cd dash-renderer
- distutils-r1_src_prepare
-}
-
-src_configure() {
- distutils-r1_src_configure
- cd dash-renderer
- distutils-r1_src_configure
-}
-
-src_compile() {
- distutils-r1_src_compile
- cd dash-renderer
- distutils-r1_src_compile
-}
-
-src_install() {
- distutils-r1_src_install
- cd dash-renderer
- distutils-r1_src_install
-}
diff --git a/sci-visualization/dash/dash-1.21.0.ebuild b/sci-visualization/dash/dash-1.21.0.ebuild
deleted file mode 100644
index 0c622cae63c1..000000000000
--- a/sci-visualization/dash/dash-1.21.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python framework for building ML & data science web apps"
-HOMEPAGE="https://github.com/plotly/dash"
-SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Test need some packages not yet in the tree
-# flask_talisman
-# percy
-# ...
-RESTRICT="test"
-
-RDEPEND="
- dev-python/future[${PYTHON_USEDEP}]
- sci-visualization/dash-table[${PYTHON_USEDEP}]
- sci-visualization/dash-html-components[${PYTHON_USEDEP}]
- sci-visualization/dash-core-components[${PYTHON_USEDEP}]
- dev-python/plotly[${PYTHON_USEDEP}]
- dev-python/flask-compress[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/beautifulsoup4 )"
-BDEPEND=""
-
-distutils_enable_tests pytest