summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 16:00:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 16:04:15 +0200
commit3c6ef59a160bc86988013b33dd19c7eee3280cd6 (patch)
treee3c76e3b055ac8dafff0654f24f69a6200a3062d /sci-visualization
parentsys-apps/elivepatch-client: Remove last-rited pkg (diff)
downloadgentoo-3c6ef59a160bc86988013b33dd19c7eee3280cd6.tar.gz
gentoo-3c6ef59a160bc86988013b33dd19c7eee3280cd6.tar.bz2
gentoo-3c6ef59a160bc86988013b33dd19c7eee3280cd6.zip
sci-visualization/yt: Remove last-rited pkg
Closes: https://bugs.gentoo.org/718512 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/yt/Manifest2
-rw-r--r--sci-visualization/yt/metadata.xml21
-rw-r--r--sci-visualization/yt/yt-3.3.5.ebuild41
-rw-r--r--sci-visualization/yt/yt-3.4.0.ebuild43
4 files changed, 0 insertions, 107 deletions
diff --git a/sci-visualization/yt/Manifest b/sci-visualization/yt/Manifest
deleted file mode 100644
index 9391d60a9cf0..000000000000
--- a/sci-visualization/yt/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST yt-3.3.5.tar.gz 8913208 BLAKE2B 34ed3d9fe0109d42ed09456c057447500846936247d08c3e1c8a809e1e9af99c92951bf8fb2baf0baeef3902256399b8077112b4538d5bc2972efc101ddec269 SHA512 1741ce038fc52d446a4fb9d4aab0c9af601cf5ce244979590fc218f54ae9ff2801c5d15ae039c8b51b2a56541646601243c7e3665e3339cb9150b03d869069de
-DIST yt-3.4.0.tar.gz 9989933 BLAKE2B 77e6b05f57dcb65c4893b19fc6aa52f1b25657f3b15a08b4f649fa019610f9e749534b204df1163cbad01d3cd16fec8c53277fb9480fa4f120f25076e4ad4ae1 SHA512 762a87bb01edd2c051baec671b07f5977f6842716f7ee0607a87e4f452bb0765cfa0eb7f9eb3509176d78cead23b5f0e5be08cc63a9687732b50498be4dca82e
diff --git a/sci-visualization/yt/metadata.xml b/sci-visualization/yt/metadata.xml
deleted file mode 100644
index 5b85b9893255..000000000000
--- a/sci-visualization/yt/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-astronomy@gentoo.org</email>
- <name>Gentoo Astronomy Project</name>
- </maintainer>
- <longdescription>
- yt is an analysis and visualization system written in Python,
- designed for use with Astrophysical Simulation codes. yt can process data in a
- myriad of ways and make a variety of visualizations. It is designed to be portable
- across simulation codes, and it is developed by developers from a variety of
- institutions and backgrounds.
- </longdescription>
- <use>
- <flag name="hub">Connect to the yt hub with <pkg>dev-python/girder-client</pkg></flag>
- </use>
- <upstream>
- <remote-id type="pypi">yt</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-visualization/yt/yt-3.3.5.ebuild b/sci-visualization/yt/yt-3.3.5.ebuild
deleted file mode 100644
index c8ae43e80214..000000000000
--- a/sci-visualization/yt/yt-3.3.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
-HOMEPAGE="https://yt-project.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- >=dev-python/cython-0.24[${PYTHON_USEDEP}]
- >=dev-python/setuptools-20.0[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- append-flags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- nosetests -sv --exclude=test_flake8 || die "Tests fail with ${EPYTHON} ${PWD}"
- popd >/dev/null || die
-}
diff --git a/sci-visualization/yt/yt-3.4.0.ebuild b/sci-visualization/yt/yt-3.4.0.ebuild
deleted file mode 100644
index fd01aa40a1c6..000000000000
--- a/sci-visualization/yt/yt-3.4.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
-HOMEPAGE="https://yt-project.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="hub test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/numpy-1.10.4[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/sympy-1.0[${PYTHON_USEDEP}]
- hub? ( dev-python/girder-client[${PYTHON_USEDEP}] )
-"
-DEPEND="${CDEPEND}
- >=dev-python/cython-0.24[${PYTHON_USEDEP}]
- >=dev-python/setuptools-20.0[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- append-flags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- nosetests -sv --exclude=test_flake8 || die "Tests fail with ${EPYTHON} ${PWD}"
- popd >/dev/null || die
-}