summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 11:44:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 12:12:19 +0100
commit5477382d2dd1bf4c3d6450ae744ed78c84c03fa8 (patch)
tree086c1a43cdb0bc6804d52f18d9905c8f65392af3 /sci-visualization
parentdev-python/mkdocs-git-authors-plugin: add version 0.6.4 (diff)
downloadgentoo-5477382d2dd1bf4c3d6450ae744ed78c84c03fa8.tar.gz
gentoo-5477382d2dd1bf4c3d6450ae744ed78c84c03fa8.tar.bz2
gentoo-5477382d2dd1bf4c3d6450ae744ed78c84c03fa8.zip
sci-visualization/scidavis: add version 2.7
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/scidavis/Manifest1
-rw-r--r--sci-visualization/scidavis/scidavis-2.7.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sci-visualization/scidavis/Manifest b/sci-visualization/scidavis/Manifest
index 861d0375614f..29cc21dd1d19 100644
--- a/sci-visualization/scidavis/Manifest
+++ b/sci-visualization/scidavis/Manifest
@@ -1,2 +1,3 @@
DIST scidavis-2.4.0-gh.tar.gz 9244613 BLAKE2B 5961c1c4c28a7e290940ddefb4a7a447fb2b743528bcb96d190b2638a6b0d8807dad51ceab6392e5a3081b270149d3f3fccef8db8108dfdacc71a66c55a7509e SHA512 9797daaf3239176eb8fc346fb8e579af965cfe0881e9048c77258f1165135a124aea3ec52434cc23e117ba2077313437da65f5c694f2d8a54d312997264d9318
DIST scidavis-2.4.0_p20211117.tar.gz 9248921 BLAKE2B e14d4a270ab0b7221b3e21762c4547e5d64930ddc72bf085d72d02e4756cc4c82f38b438f90dc472a05837d059650ea3718e100ad8c56762e990b11f571fce31 SHA512 f3fba2569d5ba79be1b10ffe4ed242f7a4df81fb4561388fcdb9461404ab966b21ecfdaa001518b5139eeef319e3c979109e2889d9268b07dad9c3cec970999b
+DIST scidavis-2.7.tar.gz 11765155 BLAKE2B 10e218472893cd19fe3fb6ebef0116c37167b10b1535e6d39b3eb0f6e2f9a537a75c8da5648dae41b77add089d57cafea640d0c7f4dca459c5a9ef2cc24bff18 SHA512 8063d9f5fb29f824e0183d8902dfe9a8310b6041664ac2189765953088968136f3d72fd04f667d8dfce0ede16e17593e3351f5593d70e73705f1b737bf90b4de
diff --git a/sci-visualization/scidavis/scidavis-2.7.ebuild b/sci-visualization/scidavis/scidavis-2.7.ebuild
new file mode 100644
index 000000000000..d6d6452d9a35
--- /dev/null
+++ b/sci-visualization/scidavis/scidavis-2.7.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/graphviz"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1 cmake docs virtualx xdg
+
+DESCRIPTION="Application for Scientific Data Analysis and Visualization"
+HOMEPAGE="http://scidavis.sourceforge.net/ https://github.com/SciDAVis/scidavis/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ ZLIB"
+KEYWORDS="~amd64"
+SLOT="0"
+
+IUSE="doc +muparser origin python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# requires network
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ muparser? ( dev-cpp/muParser )
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sci-libs/gsl:=
+ sys-libs/zlib[minizip]
+ x11-libs/qwt:5
+ x11-libs/qwtplot3d
+ origin? ( sci-libs/liborigin )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP}]
+ dev-python/PyQt5-sip[${PYTHON_USEDEP}]
+ >=dev-python/sip-6:5[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ test? (
+ dev-libs/unittest++
+ dev-cpp/gtest
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-muparser.patch"
+ "${FILESDIR}/${PN}-qwtplot3d.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Remove things which are packaged elsewhere
+ rm -r 3rdparty/qwt5-qt5 3rdparty/qwtplot3d 3rdparty/liborigin || die
+
+ # OF has been renamed in Gentoo https://bugs.gentoo.org/383179
+ # Note this is *not* packaged in sys-libs/zlib[minizip] because
+ # this file resides in the test directory in upstream zlib
+ sed -i -r 's:\<(O[FN])\>:_Z_\1:g' 3rdparty/minigzip/minigzip.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSCRIPTING_MUPARSER=$(usex muparser)
+ -DSCRIPTING_PYTHON=$(usex python)
+ -DPYTHON_SCRIPTDIR="$(python_get_scriptdir)"
+ -DORIGIN_IMPORT=$(usex origin)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ docs_compile
+}
+
+src_test() {
+ virtx cmake_src_test
+}