summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:06:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:50 +0100
commit92595d086962ff071c90b94ab7364e52eddfe8ef (patch)
tree5eb39dcae7ca8b11013813aeba096c451e2e0ffc /sci-visualization
parentdev-python/python-poppler-qt5: Use qmake-utils (diff)
downloadgentoo-92595d086962ff071c90b94ab7364e52eddfe8ef.tar.gz
gentoo-92595d086962ff071c90b94ab7364e52eddfe8ef.tar.bz2
gentoo-92595d086962ff071c90b94ab7364e52eddfe8ef.zip
sci-visualization/veusz: Use qmake-utils
Closes: https://bugs.gentoo.org/763921 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/veusz/veusz-3.2.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/sci-visualization/veusz/veusz-3.2.ebuild b/sci-visualization/veusz/veusz-3.2.ebuild
index 54682cc5cd73..a3d3cdd68a21 100644
--- a/sci-visualization/veusz/veusz-3.2.ebuild
+++ b/sci-visualization/veusz/veusz-3.2.ebuild
@@ -1,37 +1,44 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit desktop distutils-r1 virtualx xdg
+inherit desktop distutils-r1 qmake-utils virtualx xdg
DESCRIPTION="Qt scientific plotting package with good Postscript output"
HOMEPAGE="https://veusz.github.io/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="dbus doc hdf5"
RESTRICT="!test? ( test )"
-CDEPEND="dev-python/PyQt5[widgets,svg,printsupport,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[widgets,svg,printsupport,${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
- hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
-DEPEND="${CDEPEND}
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
src_prepare() {
distutils-r1_src_prepare
xdg_environment_reset
}
+python_compile() {
+ distutils-r1_python_compile build_ext --qmake-exe=$(qt5_get_bindir)/qmake
+}
+
python_test() {
distutils_install_for_testing
VIRTUALX_COMMAND="${EPYTHON}" \