summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:28 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:28 +0200
commitc6a718d53dd720ee8c681e7a5f87e7d340c379dc (patch)
tree4e914eda7df872cdfd023e54ee2a104ae4bdb937 /sci-visualization
parentsci-mathematics/primecount: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-c6a718d53dd720ee8c681e7a5f87e7d340c379dc.tar.gz
gentoo-c6a718d53dd720ee8c681e7a5f87e7d340c379dc.tar.bz2
gentoo-c6a718d53dd720ee8c681e7a5f87e7d340c379dc.zip
sci-visualization/paraview: [QA] use tc-check-openmp correctly
Closes: https://github.com/gentoo/gentoo/pull/25500 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/paraview-5.9.0.ebuild8
-rw-r--r--sci-visualization/paraview/paraview-5.9.1.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-visualization/paraview/paraview-5.9.0.ebuild b/sci-visualization/paraview/paraview-5.9.0.ebuild
index ce3f2c9d4d44..f3ceac1728a1 100644
--- a/sci-visualization/paraview/paraview-5.9.0.ebuild
+++ b/sci-visualization/paraview/paraview-5.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -108,8 +108,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.9.0-gcc11-include.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- [[ ${MERGE_TYPE} != "binary" ]] && use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use python && python-single-r1_pkg_setup
PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
}
diff --git a/sci-visualization/paraview/paraview-5.9.1.ebuild b/sci-visualization/paraview/paraview-5.9.1.ebuild
index ce3f2c9d4d44..f3ceac1728a1 100644
--- a/sci-visualization/paraview/paraview-5.9.1.ebuild
+++ b/sci-visualization/paraview/paraview-5.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -108,8 +108,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.9.0-gcc11-include.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- [[ ${MERGE_TYPE} != "binary" ]] && use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use python && python-single-r1_pkg_setup
PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
}