summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-06-25 09:49:42 -0700
committerJason Zaman <perfinion@gentoo.org>2022-06-25 19:37:36 -0700
commitd6c234dbe4b1231e984b4bfe15f95f0f1df9938a (patch)
treea20af51bcbac13d882d836c291c568698a3bcb80 /sci-visualization
parentsci-libs/tensorflow-estimator: add 2.9.0 (diff)
downloadgentoo-d6c234dbe4b1231e984b4bfe15f95f0f1df9938a.tar.gz
gentoo-d6c234dbe4b1231e984b4bfe15f95f0f1df9938a.tar.bz2
gentoo-d6c234dbe4b1231e984b4bfe15f95f0f1df9938a.zip
sci-visualization/tensorboard: add 2.9.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.9.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index dce8f87d1d20..e87e03b85480 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1 +1,2 @@
DIST tensorboard-2.8.0.zip 5776309 BLAKE2B b06c740fbe01c707e937018184e286fb7221391715c5ca6d843a89c9dd3a364b8693e748ccbde735d074b0abdbca65d4e2dd9a6e57b4ede61f78a661bd16e702 SHA512 3d937e41ac0abfe44cfab12f0b5269de45615c512499107a239bb348df7f3ccaabf283afcea2a7bac4a34d7b9318947c709a84154d0d2e61912138c31c86673f
+DIST tensorboard-2.9.0.zip 5797045 BLAKE2B e91988637a0e30fcd6341f02bc5e83ba92ae1f6e65a2aa5ddb1626ec4bb95a97d1306984b899279281e5d5f5ac70be76669ddc87524910861429e02259269b79 SHA512 244e117de989a56efc4120b6374d5cc6c31bb233e234cf95df9ddf7cbd0ec494b925dae238c59f3663087136bbf789284096f20b300f0b4c56c9de7faddc520b
diff --git a/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild
new file mode 100644
index 000000000000..33cd44742483
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}