summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-08 12:11:13 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-08 12:11:13 +1200
commit4f1c44a8ebff482c1e79c23221c985ae380fd155 (patch)
tree55e9bcd8f58d992972c676d83c214169e0f1a775 /sys-apps/ack/ack-2.18-r1.ebuild
parentsys-apps/ack: Fix dependency on File-Next re bug #614882 (diff)
downloadgentoo-4f1c44a8ebff482c1e79c23221c985ae380fd155.tar.gz
gentoo-4f1c44a8ebff482c1e79c23221c985ae380fd155.tar.bz2
gentoo-4f1c44a8ebff482c1e79c23221c985ae380fd155.zip
sys-apps/ack: -r1 bump to force RDEP propagation
Existing users must reinstall because they must have the newer File-Next or their ack will be broken :( Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'sys-apps/ack/ack-2.18-r1.ebuild')
-rw-r--r--sys-apps/ack/ack-2.18-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/ack/ack-2.18-r1.ebuild b/sys-apps/ack/ack-2.18-r1.ebuild
new file mode 100644
index 000000000000..82a1ae34cccd
--- /dev/null
+++ b/sys-apps/ack/ack-2.18-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="ack is a tool like grep, optimized for programmers"
+HOMEPAGE="http://betterthangrep.com/ ${HOMEPAGE}"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-perl/File-Next-1.160.0"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/IO-Tty )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.14-gentoo.patch )
+
+src_test() {
+ # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
+ # which enables interactive tests that need to read from stdin. If IO-Tty
+ # is not installed the related tests are skipped.
+ MAKEOPTS+=" -j1" perl-module_src_test
+}