summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/attr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/Manifest2
-rw-r--r--sys-apps/attr/attr-2.4.46-r2.ebuild54
-rw-r--r--sys-apps/attr/attr-2.4.47-r1.ebuild69
-rw-r--r--sys-apps/attr/attr-2.4.47-r2.ebuild69
-rw-r--r--sys-apps/attr/files/attr-2.4.44-gettext.patch63
-rw-r--r--sys-apps/attr/files/attr-2.4.46-config-shell.patch53
-rw-r--r--sys-apps/attr/files/attr-2.4.46-generic-syscalls.patch180
-rw-r--r--sys-apps/attr/metadata.xml5
8 files changed, 495 insertions, 0 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
new file mode 100644
index 000000000000..88c14e595f6b
--- /dev/null
+++ b/sys-apps/attr/Manifest
@@ -0,0 +1,2 @@
+DIST attr-2.4.46.src.tar.gz 338181 SHA256 dcd69bdca7ff166bc45141eddbcf21967999a6b66b0544be12a1cc2fd6340e1f SHA512 f1b8e6e4d1aa9f5c1b51d5d08684c9fdfa4b7d22efc1a77c13e4d5f0ae8e053bbb3d49a1c1e3c4143f63c9752ed534a2d009e0ab49cea880032620edbe8fdbb5 WHIRLPOOL 300f3be50a015f2d6d44a4707c31a312015c308899acdf146dfbbdb373336f5de7696f4832dba9543abd9cdfceccd84ef602d672fb88a125210e2622a13cf8fa
+DIST attr-2.4.47.src.tar.gz 343692 SHA256 25772f653ac5b2e3ceeb89df50e4688891e21f723c460636548971652af0a859 SHA512 2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831 WHIRLPOOL a012f7a0225e63d4d195fae7027e64c0c92edb039622bfdec611b2facbcde83eb5fc921ecfe95c50f54f7c9b518f57a0555dcedc148cc8ff6e73371668a40557
diff --git a/sys-apps/attr/attr-2.4.46-r2.ebuild b/sys-apps/attr/attr-2.4.46-r2.ebuild
new file mode 100644
index 000000000000..5d19e57e8f73
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.46-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.44-gettext.patch
+ epatch "${FILESDIR}"/${PN}-2.4.46-config-shell.patch #366671
+ epatch "${FILESDIR}"/${PN}-2.4.46-generic-syscalls.patch #460702
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ strip-linguas -u po
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ use static-libs || find "${D}" -name '*.la' -delete
+ # the man-pages packages provides the man2 files
+ rm -r "${ED}"/usr/share/man/man2
+
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+}
diff --git a/sys-apps/attr/attr-2.4.47-r1.ebuild b/sys-apps/attr/attr-2.4.47-r1.ebuild
new file mode 100644
index 000000000000..f0db984ba8ec
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.47-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die
+ strip-linguas -u po
+ multilib_copy_sources # https://savannah.nongnu.org/bugs/index.php?39736
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/bin
+}
+
+multilib_src_compile() {
+ emake $(multilib_is_native_abi || echo TOOL_SUBDIRS=)
+}
+
+multilib_src_install() {
+ emake \
+ $(multilib_is_native_abi || echo TOOL_SUBDIRS=) \
+ DIST_ROOT="${D}" \
+ install install-lib install-dev
+
+ if multilib_is_native_abi; then
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+ # the man-pages packages provides the man2 files
+ # note: man-pages are installed by TOOL_SUBDIRS
+ rm -r "${ED}"/usr/share/man/man2 || die
+ fi
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+ einstalldocs
+}
diff --git a/sys-apps/attr/attr-2.4.47-r2.ebuild b/sys-apps/attr/attr-2.4.47-r2.ebuild
new file mode 100644
index 000000000000..91ab80d8340d
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.47-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh ~sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die
+ strip-linguas -u po
+ multilib_copy_sources # https://savannah.nongnu.org/bugs/index.php?39736
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/bin
+}
+
+multilib_src_compile() {
+ emake $(multilib_is_native_abi || echo TOOL_SUBDIRS=)
+}
+
+multilib_src_install() {
+ emake \
+ $(multilib_is_native_abi || echo TOOL_SUBDIRS=) \
+ DIST_ROOT="${D}" \
+ install install-lib install-dev
+
+ if multilib_is_native_abi; then
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+ # the man-pages packages provides the man2 files
+ # note: man-pages are installed by TOOL_SUBDIRS
+ rm -r "${ED}"/usr/share/man/man2 "${ED}"/usr/share/man/man5/attr.5 || die
+ fi
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+ einstalldocs
+}
diff --git a/sys-apps/attr/files/attr-2.4.44-gettext.patch b/sys-apps/attr/files/attr-2.4.44-gettext.patch
new file mode 100644
index 000000000000..49c2d32bdce4
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.44-gettext.patch
@@ -0,0 +1,63 @@
+--- include/gettext.h
++++ include/gettext.h
+@@ -0,0 +1,10 @@
++#include <config.h>
++#ifdef ENABLE_GETTEXT
++# include <libintl.h>
++# define _(x) gettext(x)
++#else
++# define _(x) (x)
++# define textdomain(d) do { } while (0)
++# define bindtextdomain(d,dir) do { } while (0)
++#endif
++#include <locale.h>
+--- attr/attr.c
++++ attr/attr.c
+@@ -26,6 +26,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <locale.h>
++#include "gettext.h"
+
+ #include <attr/attributes.h>
+ #include "config.h"
+--- libattr/attr_copy_file.c.orig 2007-09-20 02:51:37.000000000 -0400
++++ libattr/attr_copy_file.c 2007-09-20 02:51:51.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #if defined (HAVE_CONFIG_H)
+ #include "config.h"
++#include "gettext.h"
+ #endif
+
+ #include <sys/types.h>
+--- libattr/attr_copy_fd.c.orig 2007-09-20 02:52:23.000000000 -0400
++++ libattr/attr_copy_fd.c 2007-09-20 02:52:31.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #if defined (HAVE_CONFIG_H)
+ #include "config.h"
++#include "gettext.h"
+ #endif
+
+ #include <sys/types.h>
+--- getfattr/getfattr.c.orig 2007-09-20 02:52:49.000000000 -0400
++++ getfattr/getfattr.c 2007-09-20 02:52:59.000000000 -0400
+@@ -30,6 +30,7 @@
+ #include <regex.h>
+ #include <ftw.h>
+ #include <locale.h>
++#include "gettext.h"
+
+ #include <attr/xattr.h>
+ #include "config.h"
+--- setfattr/setfattr.c.orig 2007-09-20 02:53:12.000000000 -0400
++++ setfattr/setfattr.c 2007-09-20 02:53:20.000000000 -0400
+@@ -28,6 +28,7 @@
+ #include <getopt.h>
+ #include <locale.h>
+ #include <ctype.h>
++#include "gettext.h"
+
+ #include <attr/xattr.h>
+ #include "config.h"
diff --git a/sys-apps/attr/files/attr-2.4.46-config-shell.patch b/sys-apps/attr/files/attr-2.4.46-config-shell.patch
new file mode 100644
index 000000000000..b6660e63c03c
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.46-config-shell.patch
@@ -0,0 +1,53 @@
+https://bugs.gentoo.org/366671
+
+From 10bfb16245ec4b55c1f5b6dc5554913bc9b13c9c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 16 May 2011 01:59:52 -0400
+Subject: [PATCH] use SHELL from configure
+
+If /bin/sh is not a functional enough shell, configure will select a
+SHELL of /bin/bash or better. But the current build helpers always
+hardcode /bin/sh, so if libtool itself configures itself for /bin/bash,
+things will fail when it attempts to do:
+ SHELL = /bin/sh
+ LIBTOOL = $(SHELL) .../libtool
+ ...
+ eval: 1: base_compile+= -pipe: not found
+ ...
+
+So rather than hardcoding SHELL to /bin/sh, set it to @SHELL@ and let
+configure find a good value for us.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/builddefs.in | 1 +
+ include/buildmacros | 1 -
+ 2 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/include/builddefs.in b/include/builddefs.in
+index d054a56..434ce95 100644
+--- a/include/builddefs.in
++++ b/include/builddefs.in
+@@ -46,6 +46,7 @@ MAKE = @make@
+ ECHO = @echo@
+ SORT = @sort@
+ LN_S = @LN_S@
++SHELL = @SHELL@
+ LIBTOOL = @LIBTOOL@
+ MAKEDEPEND = @makedepend@
+
+diff --git a/include/buildmacros b/include/buildmacros
+index ab89182..8efb32e 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -42,7 +42,6 @@ OBJECTS = $(ASFILES:.s=.o) \
+
+ INSTALL = $(TOPDIR)/include/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
+
+-SHELL = /bin/sh
+ IMAGES_DIR = $(TOPDIR)/all-images
+ DIST_DIR = $(TOPDIR)/dist
+
+--
+1.7.5.rc3
+
diff --git a/sys-apps/attr/files/attr-2.4.46-generic-syscalls.patch b/sys-apps/attr/files/attr-2.4.46-generic-syscalls.patch
new file mode 100644
index 000000000000..d12fcd29afd1
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.46-generic-syscalls.patch
@@ -0,0 +1,180 @@
+http://lists.nongnu.org/archive/html/acl-devel/2012-12/msg00000.html
+https://bugs.gentoo.org/460702
+
+--- a/libattr/syscalls.c
++++ b/libattr/syscalls.c
+@@ -23,172 +23,10 @@
+
+ #include <errno.h>
+ #include <unistd.h>
++#include <sys/syscall.h>
+
+-#if defined (__i386__)
++#if defined (__NR_setxattr)
+ # define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 226
+-# define __NR_lsetxattr 227
+-# define __NR_fsetxattr 228
+-# define __NR_getxattr 229
+-# define __NR_lgetxattr 230
+-# define __NR_fgetxattr 231
+-# define __NR_listxattr 232
+-# define __NR_llistxattr 233
+-# define __NR_flistxattr 234
+-# define __NR_removexattr 235
+-# define __NR_lremovexattr 236
+-# define __NR_fremovexattr 237
+-#elif defined (__sparc__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 169
+-# define __NR_lsetxattr 170
+-# define __NR_fsetxattr 171
+-# define __NR_getxattr 172
+-# define __NR_lgetxattr 173
+-# define __NR_fgetxattr 177
+-# define __NR_listxattr 178
+-# define __NR_llistxattr 179
+-# define __NR_flistxattr 180
+-# define __NR_removexattr 181
+-# define __NR_lremovexattr 182
+-# define __NR_fremovexattr 186
+-#elif defined (__ia64__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 1217
+-# define __NR_lsetxattr 1218
+-# define __NR_fsetxattr 1219
+-# define __NR_getxattr 1220
+-# define __NR_lgetxattr 1221
+-# define __NR_fgetxattr 1222
+-# define __NR_listxattr 1223
+-# define __NR_llistxattr 1224
+-# define __NR_flistxattr 1225
+-# define __NR_removexattr 1226
+-# define __NR_lremovexattr 1227
+-# define __NR_fremovexattr 1228
+-#elif defined (__powerpc__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 209
+-# define __NR_lsetxattr 210
+-# define __NR_fsetxattr 211
+-# define __NR_getxattr 212
+-# define __NR_lgetxattr 213
+-# define __NR_fgetxattr 214
+-# define __NR_listxattr 215
+-# define __NR_llistxattr 216
+-# define __NR_flistxattr 217
+-# define __NR_removexattr 218
+-# define __NR_lremovexattr 219
+-# define __NR_fremovexattr 220
+-#elif defined (__x86_64__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 188
+-# define __NR_lsetxattr 189
+-# define __NR_fsetxattr 190
+-# define __NR_getxattr 191
+-# define __NR_lgetxattr 192
+-# define __NR_fgetxattr 193
+-# define __NR_listxattr 194
+-# define __NR_llistxattr 195
+-# define __NR_flistxattr 196
+-# define __NR_removexattr 197
+-# define __NR_lremovexattr 198
+-# define __NR_fremovexattr 199
+-#elif defined (__s390__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 224
+-# define __NR_lsetxattr 225
+-# define __NR_fsetxattr 226
+-# define __NR_getxattr 227
+-# define __NR_lgetxattr 228
+-# define __NR_fgetxattr 229
+-# define __NR_listxattr 230
+-# define __NR_llistxattr 231
+-# define __NR_flistxattr 232
+-# define __NR_removexattr 233
+-# define __NR_lremovexattr 234
+-# define __NR_fremovexattr 235
+-#elif defined (__arm__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# if defined(__ARM_EABI__) || defined(__thumb__)
+-# define __NR_SYSCALL_BASE 0
+-# else
+-# define __NR_SYSCALL_BASE 0x900000
+-# endif
+-# define __NR_setxattr (__NR_SYSCALL_BASE+226)
+-# define __NR_lsetxattr (__NR_SYSCALL_BASE+227)
+-# define __NR_fsetxattr (__NR_SYSCALL_BASE+228)
+-# define __NR_getxattr (__NR_SYSCALL_BASE+229)
+-# define __NR_lgetxattr (__NR_SYSCALL_BASE+230)
+-# define __NR_fgetxattr (__NR_SYSCALL_BASE+231)
+-# define __NR_listxattr (__NR_SYSCALL_BASE+232)
+-# define __NR_llistxattr (__NR_SYSCALL_BASE+233)
+-# define __NR_flistxattr (__NR_SYSCALL_BASE+234)
+-# define __NR_removexattr (__NR_SYSCALL_BASE+235)
+-# define __NR_lremovexattr (__NR_SYSCALL_BASE+236)
+-# define __NR_fremovexattr (__NR_SYSCALL_BASE+237)
+-#elif defined (__mips64)
+-# define HAVE_XATTR_SYSCALLS 1
+-# ifdef __LP64__ /* mips64 using n64 ABI */
+-# define __NR_Linux 5000
+-# else /* mips64 using n32 ABI */
+-# define __NR_Linux 6000
+-# endif
+-# define __NR_setxattr (__NR_Linux + 180)
+-# define __NR_lsetxattr (__NR_Linux + 181)
+-# define __NR_fsetxattr (__NR_Linux + 182)
+-# define __NR_getxattr (__NR_Linux + 183)
+-# define __NR_lgetxattr (__NR_Linux + 184)
+-# define __NR_fgetxattr (__NR_Linux + 185)
+-# define __NR_listxattr (__NR_Linux + 186)
+-# define __NR_llistxattr (__NR_Linux + 187)
+-# define __NR_flistxattr (__NR_Linux + 188)
+-# define __NR_removexattr (__NR_Linux + 189)
+-# define __NR_lremovexattr (__NR_Linux + 190)
+-# define __NR_fremovexattr (__NR_Linux + 191)
+-#elif defined (__mips__) /* mips32, or mips64 using o32 ABI */
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_Linux 4000
+-# define __NR_setxattr (__NR_Linux + 224)
+-# define __NR_lsetxattr (__NR_Linux + 225)
+-# define __NR_fsetxattr (__NR_Linux + 226)
+-# define __NR_getxattr (__NR_Linux + 227)
+-# define __NR_lgetxattr (__NR_Linux + 228)
+-# define __NR_fgetxattr (__NR_Linux + 229)
+-# define __NR_listxattr (__NR_Linux + 230)
+-# define __NR_llistxattr (__NR_Linux + 231)
+-# define __NR_flistxattr (__NR_Linux + 232)
+-# define __NR_removexattr (__NR_Linux + 233)
+-# define __NR_lremovexattr (__NR_Linux + 234)
+-# define __NR_fremovexattr (__NR_Linux + 235)
+-#elif defined (__alpha__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 382
+-# define __NR_lsetxattr 383
+-# define __NR_fsetxattr 384
+-# define __NR_getxattr 385
+-# define __NR_lgetxattr 386
+-# define __NR_fgetxattr 387
+-# define __NR_listxattr 388
+-# define __NR_llistxattr 389
+-# define __NR_flistxattr 390
+-# define __NR_removexattr 391
+-# define __NR_lremovexattr 392
+-# define __NR_fremovexattr 393
+-#elif defined (__mc68000__)
+-# define HAVE_XATTR_SYSCALLS 1
+-# define __NR_setxattr 223
+-# define __NR_lsetxattr 224
+-# define __NR_fsetxattr 225
+-# define __NR_getxattr 226
+-# define __NR_lgetxattr 227
+-# define __NR_fgetxattr 228
+-# define __NR_listxattr 229
+-# define __NR_llistxattr 230
+-# define __NR_flistxattr 231
+-# define __NR_removexattr 232
+-# define __NR_lremovexattr 233
+-# define __NR_fremovexattr 234
+ #else
+ # warning "Extended attribute syscalls undefined for this architecture"
+ # define HAVE_XATTR_SYSCALLS 0
diff --git a/sys-apps/attr/metadata.xml b/sys-apps/attr/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/attr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>