summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-09 16:19:24 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-09 16:19:40 +0100
commit79c3dd924b4a170d77d3eab29ab9b25fad6f0f3d (patch)
tree18aee7ec676263d940055f055a38dab249475661 /sys-apps/attr
parentdev-python/unidecode: Version 1.0.22. (diff)
downloadgentoo-79c3dd924b4a170d77d3eab29ab9b25fad6f0f3d.tar.gz
gentoo-79c3dd924b4a170d77d3eab29ab9b25fad6f0f3d.tar.bz2
gentoo-79c3dd924b4a170d77d3eab29ab9b25fad6f0f3d.zip
sys-apps/attr: Bump to version 2.4.48
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/Manifest1
-rw-r--r--sys-apps/attr/attr-2.4.48.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index 16cf20ce4d17..40cfb3281728 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1 +1,2 @@
DIST attr-2.4.47.src.tar.gz 343692 BLAKE2B af4d509f156cb2e693f0faebf1a6cfb4a27cbdd3fd7f8b436cc01419c905ff9ac36214ada2ca8269e49c2e276917b1178dcda97050cf25cecd65382f22bdf9bb SHA512 2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831
+DIST attr-2.4.48.tar.xz 346292 BLAKE2B eeffc17bf485749b5d0a1fce4ac3702c33a0bacce3ad635400e8b0b52981f14c5e750ef570f8fd19657e460e51e6e09f972134ef8a3e6efc15c2a7203682df75 SHA512 78b8160303aec9e01f63b5cf725a9e16432ff1d4a6e0065ce1a52715ae1266572e0c01f9be25c938c484deea288fdff2ce27981c3aea578753ad854084957e8b
diff --git a/sys-apps/attr/attr-2.4.48.ebuild b/sys-apps/attr/attr-2.4.48.ebuild
new file mode 100644
index 000000000000..086cfe28d390
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.48.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="https://savannah.nongnu.org/projects/attr"
+# Self-hosting as savannah does not provide a tarball on their download
+# area and the tarball in their git repo requires autoreconf to be run.
+SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug static-libs"
+
+DEPEND="
+ sys-devel/autoconf
+ sys-devel/gettext
+"
+
+src_prepare() {
+ default
+ elibtoolize #580792
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-shared $(use_enable static-libs static)
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable debug)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi; then
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+ fi
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+ einstalldocs
+}