summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-02 16:27:55 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-02 17:14:57 +0100
commit923c2c30d714f38ab7b8b59e88356a86a5c3bf47 (patch)
tree13afd7b3a39f0e1aafb92aea1fb364621ed9f736 /sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
parentsys-apps/arrayprobe: Port to EAPI 6 (diff)
downloadgentoo-923c2c30d714f38ab7b8b59e88356a86a5c3bf47.tar.gz
gentoo-923c2c30d714f38ab7b8b59e88356a86a5c3bf47.tar.bz2
gentoo-923c2c30d714f38ab7b8b59e88356a86a5c3bf47.zip
sys-apps/audio-entropyd: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild')
-rw-r--r--sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild b/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
index 5e5a60fb72c6..cab08ef38cf8 100644
--- a/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
+++ b/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils systemd toolchain-funcs
+EAPI=6
+
+inherit systemd toolchain-funcs
DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device"
HOMEPAGE="http://www.vanheusden.com/aed/"
@@ -13,25 +14,32 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE="selinux"
-RDEPEND="selinux? ( sec-policy/selinux-entropyd )
+DEPEND="media-libs/alsa-lib:="
+RDEPEND="${DEPEND}
media-sound/alsa-utils
- media-libs/alsa-lib"
+ selinux? ( sec-policy/selinux-entropyd )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.1-uclibc.patch
+ "${FILESDIR}"/${PN}-2.0.1-ldflags.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${PN}-2.0.1-uclibc.patch" \
- "${FILESDIR}/${PN}-2.0.1-ldflags.patch"
+ default
+
sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" \
-e "/^WARNFLAGS/s: -g::" Makefile || die
}
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
src_install() {
dosbin audio-entropyd
- dodoc README TODO
- systemd_dounit "${FILESDIR}/${PN}.service"
- newinitd "${FILESDIR}/${PN}.init-2" ${PN}
- newconfd "${FILESDIR}/${PN}.conf-2" ${PN}
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ newinitd "${FILESDIR}"/${PN}.init-2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf-2 ${PN}
}