summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-24 00:39:21 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-24 01:00:19 +0200
commit32d7ca58e72320ad3f45521e8165490642a6629e (patch)
tree9cc9e12753f04c184341394240864c223569d98f /sys-apps/baobab/baobab-3.22.0.ebuild
parentnet-misc/vino: cleanup old revision (diff)
downloadgentoo-32d7ca58e72320ad3f45521e8165490642a6629e.tar.gz
gentoo-32d7ca58e72320ad3f45521e8165490642a6629e.tar.bz2
gentoo-32d7ca58e72320ad3f45521e8165490642a6629e.zip
sys-apps/baobab: version bump 3.20.1 → 3.22.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-apps/baobab/baobab-3.22.0.ebuild')
-rw-r--r--sys-apps/baobab/baobab-3.22.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/baobab/baobab-3.22.0.ebuild b/sys-apps/baobab/baobab-3.22.0.ebuild
new file mode 100644
index 000000000000..f71cd4fcb72a
--- /dev/null
+++ b/sys-apps/baobab/baobab-3.22.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Disk usage browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2[dbus]
+ >=x11-libs/gtk+-3.19.1:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/adwaita-icon-theme
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ VALAC=$(type -P true) \
+ VAPIGEN=$(type -P true)
+}