summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-02-23 15:26:10 +0800
committerJason Zaman <perfinion@gentoo.org>2017-02-23 19:14:26 +0800
commite952d558c72b6929b058f4bf084379c9005e646b (patch)
treed15c0e9c164fd4cd2ab97cbe5db567f550664ffc /sys-apps/checkpolicy
parentsys-libs/libsemanage: update live ebuild (diff)
downloadgentoo-e952d558c72b6929b058f4bf084379c9005e646b.tar.gz
gentoo-e952d558c72b6929b058f4bf084379c9005e646b.tar.bz2
gentoo-e952d558c72b6929b058f4bf084379c9005e646b.zip
sys-apps/checkpolicy: update live ebuild
need to pass the path to libsepol.a Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-9999.ebuild b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
index ae94993763f9..f27b7d320b71 100644
--- a/sys-apps/checkpolicy/checkpolicy-9999.ebuild
+++ b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -37,11 +37,16 @@ DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
src_compile() {
- emake CC="$(tc-getCC)" YACC="bison -y" LIBDIR="\$(PREFIX)/$(get_libdir)"
+ emake \
+ CC="$(tc-getCC)" \
+ YACC="bison -y" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" \
+ LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
+ install
if use debug; then
dobin "${S}/test/dismod"