summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/checkservice/checkservice-1.2.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/checkservice/checkservice-1.2.0.ebuild')
-rw-r--r--sys-apps/checkservice/checkservice-1.2.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/checkservice/checkservice-1.2.0.ebuild b/sys-apps/checkservice/checkservice-1.2.0.ebuild
new file mode 100644
index 000000000000..4facf835a5b5
--- /dev/null
+++ b/sys-apps/checkservice/checkservice-1.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Check the status of services running on local/remote machines"
+HOMEPAGE="http://www.linvision.com/checkservice/"
+SRC_URI="http://www.linvision.com/checkservice/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-perl/MailTools-1.58
+ >=dev-perl/File-Find-Rule-0.26
+ >=virtual/perl-Getopt-Long-2.34"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:/usr/local:/usr:g' $(grep -rl /usr/local *) || die "sed /usr/local"
+}
+
+src_install() {
+ dodir /var/{log,lock,cache}/checkservice
+ dobin checkservice || die
+
+ insinto /usr/lib/checkservice/check
+ doins plugins/check/* || die "check"
+ insinto /usr/lib/checkservice/warning
+ doins plugins/warning/* || die "warning"
+
+ insinto /usr/lib/perl5/vendor_perl/CS
+ doins lib/CS/* || die "perl5"
+
+ insinto /etc/checkservice/config
+ doins config/{*.mail,*.conf}
+ insinto /etc/checkservice/config/plugins/warning
+ doins config/plugins/warning/*
+
+ doman man/*
+ dodoc INSTALL README TODO checkservice.php cron/checkservice
+}
+
+pkg_postinst() {
+ einfo "If you want a php status page or cron checkservice"
+ einfo "read the INSTALL file in docs directory all files"
+ einfo "and info are there"
+}