summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/cpuid/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/cpuid/files')
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-Makefile.patch30
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-fPIC.patch24
-rw-r--r--sys-apps/cpuid/files/cpuid-20150606-Makefile.patch21
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
new file mode 100644
index 000000000000..a3aab8a50f66
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
@@ -0,0 +1,30 @@
+Index: cpuid-20110305/Makefile
+===================================================================
+--- cpuid-20110305.orig/Makefile
++++ cpuid-20110305/Makefile
+@@ -1,7 +1,3 @@
+-CFLAGS=-g
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -36,14 +32,14 @@ BUILDROOT=
+ default: $(PROG) $(PROG).man.gz
+
+ $(PROG): cpuid.c Makefile
+- $(CC) $(CFL) -o $@ cpuid.c
++ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+
+ $(PROG).man.gz: $(PROG).man
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch b/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
new file mode 100644
index 000000000000..80cc6774a188
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
@@ -0,0 +1,24 @@
+diff -u cpuid-20110305.orig//cpuid.c cpuid-20110305/cpuid.c
+--- cpuid-20110305.orig//cpuid.c 2011-03-04 13:25:16.000000000 -0500
++++ cpuid-20110305/cpuid.c 2011-07-31 01:53:39.647437813 -0400
+@@ -5319,9 +5319,20 @@
+ boolean quiet)
+ {
+ if (cpuid_fd == USE_INSTRUCTION) {
++#if defined(__i386__) && defined(__PIC__)
++ asm("push %%ebx\n"
++ "cpuid\n"
++ "movl %%ebx, %1\n"
++ "pop %%ebx\n"
++#else
+ asm("cpuid"
++#endif
+ : "=a" (words[WORD_EAX]),
++#if defined(__i386__) && defined(__PIC__)
++ "=r" (words[WORD_EBX]),
++#else
+ "=b" (words[WORD_EBX]),
++#endif
+ "=c" (words[WORD_ECX]),
+ "=d" (words[WORD_EDX])
+ : "a" (reg),
diff --git a/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
new file mode 100644
index 000000000000..f878977ece91
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
@@ -0,0 +1,21 @@
+--- cpuid-20150606/Makefile
++++ cpuid-20150606/Makefile
+@@ -1,9 +1,3 @@
+-CFLAGS+=-g
+-CPPFLAGS?=
+-LDFLAGS?=
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -44,7 +38,7 @@
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean: