summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-21 10:30:21 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-21 10:30:21 +0200
commit8d20cb40b869f8d94f410dad378348cc9873db11 (patch)
tree675e077a9dfdc482224bb822b986ea218273326a /sys-apps/diffutils/diffutils-3.5.ebuild
parentdev-python/zope-interface: version bump to 4.2.0 (diff)
downloadgentoo-8d20cb40b869f8d94f410dad378348cc9873db11.tar.gz
gentoo-8d20cb40b869f8d94f410dad378348cc9873db11.tar.bz2
gentoo-8d20cb40b869f8d94f410dad378348cc9873db11.zip
sys-apps/diffutils: Bump to version 3.5
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/diffutils/diffutils-3.5.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-3.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/diffutils/diffutils-3.5.ebuild b/sys-apps/diffutils/diffutils-3.5.ebuild
new file mode 100644
index 000000000000..94ca67dd815e
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="https://www.gnu.org/software/diffutils/"
+SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
+ mirror://gnu-alpha/diffutils/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+DEPEND="app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/" \
+ $(use_enable nls)
+}
+
+src_test() {
+ # explicitly allow parallel testing
+ emake check
+}