summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dmapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/Manifest1
-rw-r--r--sys-apps/dmapi/dmapi-2.2.12-r1.ebuild48
-rw-r--r--sys-apps/dmapi/dmapi-2.2.12.ebuild42
-rw-r--r--sys-apps/dmapi/metadata.xml5
4 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/dmapi/Manifest b/sys-apps/dmapi/Manifest
new file mode 100644
index 000000000000..01e9ed5090d6
--- /dev/null
+++ b/sys-apps/dmapi/Manifest
@@ -0,0 +1 @@
+DIST dmapi-2.2.12.tar.gz 367318 SHA256 b18e34f47374f6adf7c164993c26df36986a009b86aa004ef9444102653aea69 SHA512 aa44c0c7857158fed198deb9d1e00abaab549e3c22a7ce0e24e6088146bde56ecf967405b1b61a589460981ddcfaffbb1e9a2e677088efec317e3a7cb44abe4f WHIRLPOOL 5209b3a3b8afaf55eb26588cd8ffe085f58849b0b4a159851c0ffeefa0f8cf5aad53d9bea927099f3fced101e017867c538a081667ad684df5f2ff6685eac19e
diff --git a/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild b/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
new file mode 100644
index 000000000000..54291171b34a
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="sys-fs/xfsprogs"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install install-dev
+ multilib_is_native_abi && gen_usr_ldscript -a dm
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ rm "${ED}"/usr/share/doc/${PF}/COPYING
+}
diff --git a/sys-apps/dmapi/dmapi-2.2.12.ebuild b/sys-apps/dmapi/dmapi-2.2.12.ebuild
new file mode 100644
index 000000000000..7b357aa2f049
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="sys-fs/xfsprogs"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+}
+
+src_configure() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-dev
+ gen_usr_ldscript -a dm
+ find "${ED}"/usr '(' -name '*.la' -o -name COPYING ')' -delete
+}
diff --git a/sys-apps/dmapi/metadata.xml b/sys-apps/dmapi/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/dmapi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>