summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-07 08:59:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-07 08:59:44 +0200
commit46877d4ff1729a03119b5478b120192241379eef (patch)
tree8f79d7ac401b177f1d16fa33bfa923e3651248cf /sys-apps/dmidecode/dmidecode-3.0.ebuild
parentdev-libs/libexplain: Drop old (diff)
downloadgentoo-46877d4ff1729a03119b5478b120192241379eef.tar.gz
gentoo-46877d4ff1729a03119b5478b120192241379eef.tar.bz2
gentoo-46877d4ff1729a03119b5478b120192241379eef.zip
sys-apps/dmidecode: Bump to version 3.0
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-3.0.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.0.ebuild b/sys-apps/dmidecode/dmidecode-3.0.ebuild
new file mode 100644
index 000000000000..4cae2bc805ce
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}