summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-17 09:56:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-17 09:56:42 +0200
commitd33ea761e24053b6c17ec3dfd0229d6c793f330d (patch)
treea031cd068e9997a2ab5be50f939b899bf4dba9c7 /sys-apps/dmidecode/dmidecode-3.2.ebuild
parentbsdmk.eclass: Add verbose output of bmake calls (diff)
downloadgentoo-d33ea761e24053b6c17ec3dfd0229d6c793f330d.tar.gz
gentoo-d33ea761e24053b6c17ec3dfd0229d6c793f330d.tar.bz2
gentoo-d33ea761e24053b6c17ec3dfd0229d6c793f330d.zip
sys-apps/dmidecode: Bump to version 3.2
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-3.2.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.2.ebuild b/sys-apps/dmidecode/dmidecode-3.2.ebuild
new file mode 100644
index 000000000000..3d98eebf5a00
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="https://www.nongnu.org/dmidecode/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}