summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dog')
-rw-r--r--sys-apps/dog/Manifest1
-rw-r--r--sys-apps/dog/dog-1.7-r4.ebuild43
-rw-r--r--sys-apps/dog/files/1.7-manpage-touchup.patch18
-rw-r--r--sys-apps/dog/files/dog-1.7-64bit-goodness.patch33
-rw-r--r--sys-apps/dog/files/dog-1.7-check-ctime.diff53
-rw-r--r--sys-apps/dog/files/dog-1.7-strfry.patch13
-rw-r--r--sys-apps/dog/metadata.xml5
7 files changed, 166 insertions, 0 deletions
diff --git a/sys-apps/dog/Manifest b/sys-apps/dog/Manifest
new file mode 100644
index 000000000000..938907b76a9d
--- /dev/null
+++ b/sys-apps/dog/Manifest
@@ -0,0 +1 @@
+DIST dog-1.7.tar.gz 30433 RMD160 dd8867a5a8ff7208b92df8bc23a9b6b48cc74816 SHA1 a1af9c76daa0c9768cdf0c31839b3004e6ccc417 SHA256 6c5386d1b6401d6410baa8f0da343de5625cd3d59b6273dcee81997c372522ca
diff --git a/sys-apps/dog/dog-1.7-r4.ebuild b/sys-apps/dog/dog-1.7-r4.ebuild
new file mode 100644
index 000000000000..2bd8abc03dcd
--- /dev/null
+++ b/sys-apps/dog/dog-1.7-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dog is better than cat"
+# the best HOMEPAGE we have.
+HOMEPAGE="http://packages.gentoo.org/package/sys-apps/dog"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc64-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-check-ctime.diff \
+ "${FILESDIR}"/${PV}-manpage-touchup.patch \
+ "${FILESDIR}"/${P}-64bit-goodness.patch \
+ "${FILESDIR}"/${P}-strfry.patch
+
+ if [[ "${CHOST}" == *-solaris* ]]
+ then
+ sed -i '/gcc.*-o dog/s/$/ -lsocket/' \
+ Makefile || die "sed Makefile failed"
+ fi
+
+ sed -i \
+ -e 's,^CFLAGS,#CFLAGS,' \
+ -e "s,gcc,$(tc-getCC)," \
+ -e 's:-o dog:$(LDFLAGS) -o dog:g' \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ dobin dog || die
+ doman dog.1 || die
+ dodoc README AUTHORS || die
+}
diff --git a/sys-apps/dog/files/1.7-manpage-touchup.patch b/sys-apps/dog/files/1.7-manpage-touchup.patch
new file mode 100644
index 000000000000..324c82696705
--- /dev/null
+++ b/sys-apps/dog/files/1.7-manpage-touchup.patch
@@ -0,0 +1,18 @@
+The correct syntax of the -w option does not have a space between
+the -w and the cols ... the manpage seems to imply differently though
+so let's fix it.
+
+http://bugs.gentoo.org/show_bug.cgi?id=69660
+
+--- dog.1
++++ dog.1
+@@ -8,3 +8,3 @@
+ .B dog
+-[\-AbBeEnstTuv] [\-w cols] [\-l lines]
++[\-AbBeEnstTuv] [\-w<cols>] [\-l lines]
+ [\-\-show\-all] [\-\-number\-nonblank] [\-\-no\-blanks] [\-\-bind=port]
+@@ -64,3 +64,3 @@
+ .TP
+-.I \-w n
++.I \-w<n>
+ Print first n characters of each line (default=80)
diff --git a/sys-apps/dog/files/dog-1.7-64bit-goodness.patch b/sys-apps/dog/files/dog-1.7-64bit-goodness.patch
new file mode 100644
index 000000000000..9143761852c1
--- /dev/null
+++ b/sys-apps/dog/files/dog-1.7-64bit-goodness.patch
@@ -0,0 +1,33 @@
+diff -ur dog-1.7/dog.c dog-1.7-64bit/dog.c
+--- dog-1.7/dog.c 2000-06-21 18:04:43.000000000 +0200
++++ dog-1.7-64bit/dog.c 2005-05-23 10:40:58.613766328 +0200
+@@ -38,22 +38,13 @@
+ #include <limits.h>
+ #include <netdb.h>
+
+-// this is fun
+-#if defined(__alpha)
+-#define uint16 unsigned short
+-#define int16 short
+-#define uint32 unsigned int
+-#define int32 int
+-#define uint64 unsigned long
+-#define int64 long
+-#else
+-#define uint16 unsigned short
+-#define int16 short
+-#define uint32 unsigned long
+-#define int32 long
+-#define uint64 unsigned long long
+-#define int64 long long
+-#endif
++#define uint16 uint16_t
++#define int16 int16_t
++#define uint32 uint32_t
++#define int32 int32_t
++#define uint64 uint64_t
++#define int64 int64_t
++
+ #if defined(__STDC__)
+ #define __dog_signed signed
+ #else
diff --git a/sys-apps/dog/files/dog-1.7-check-ctime.diff b/sys-apps/dog/files/dog-1.7-check-ctime.diff
new file mode 100644
index 000000000000..43f8aa0a8c91
--- /dev/null
+++ b/sys-apps/dog/files/dog-1.7-check-ctime.diff
@@ -0,0 +1,53 @@
+diff --exclude='*~' --exclude='.*' -I '# $Id$
+--- dog-1.7.orig/dog.c 2005-05-13 08:01:37.000000000 -0400
++++ dog-1.7/dog.c 2005-05-13 08:30:38.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include <string.h>
+ #include "getopt.h"
+ #include <limits.h>
++#include <time.h>
+ #include <netdb.h>
+
+ // this is fun
+@@ -1321,26 +1322,35 @@
+ InetSockAddr sa;
+ int newsock;
+ uint32 ipAddr;
+- int k;
++ socklen_t k;
+ time_t curr_time;
+ char curr_date[64];
+
+ k = sizeof(sa);
+ while ((newsock=accept(sock,(struct sockaddr*)&sa,&k)) != -1) {
+ if (!no_bind_header) {
++ char *result = NULL;
+ ipAddr = ntohl(sa.addr);
+ time(&curr_time);
+- strcpy(curr_date,ctime(&curr_time));
++ if (!(result = ctime(&curr_time))) {
++ perror("ctime");
++ goto done;
++ }
++ strncpy(curr_date, result, sizeof(curr_date) - 1);
+ while (!isalnum(curr_date[strlen(curr_date)-1])) {
+ curr_date[strlen(curr_date)-1] = 0;
+ }
+ printf("# %s from %d.%d.%d.%d:%d\n",curr_date,(int)ipAddr>>24,(int)(ipAddr>>16)&0xff,(int)(ipAddr>>8)&0xff,(int)ipAddr&0xff,ntohs(sa.port));
+ }
+- straight_dump = newsock;
+- DumpThings(argc,argv,hang_up_bind ? -1 : newsock);
+- if (hang_up_bind) {
++
++ goto done;
++
++ done:
++ straight_dump = newsock;
++ DumpThings(argc,argv,hang_up_bind ? -1 : newsock);
++ if (hang_up_bind) {
+ close(newsock);
+- }
++ }
+ }
+ }
+
diff --git a/sys-apps/dog/files/dog-1.7-strfry.patch b/sys-apps/dog/files/dog-1.7-strfry.patch
new file mode 100644
index 000000000000..b62b815aed50
--- /dev/null
+++ b/sys-apps/dog/files/dog-1.7-strfry.patch
@@ -0,0 +1,13 @@
+See Gentoo bug 251675. Upstream appears to be dead.
+
+--- dog.c.orig 2009-04-09 23:29:16.307661147 -0500
++++ dog.c 2009-04-09 23:30:11.353664890 -0500
+@@ -552,7 +552,7 @@
+
+ // strfry()
+ #if ALLOW_STRFRY
+- if (opt_strfry) {
++ if (opt_strfry && str_len > 0) {
+ strfry(str);
+ }
+ #endif
diff --git a/sys-apps/dog/metadata.xml b/sys-apps/dog/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/sys-apps/dog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>