summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-11 08:54:13 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-11 08:54:36 +0200
commit2285858b273aaee97543477467b306747880c81f (patch)
treea0e055a927e11e04e6c99d4c32f075145a4c7320 /sys-apps/dtc/dtc-1.4.2.ebuild
parentdev-ruby/rbtree: fix installation of files (diff)
downloadgentoo-2285858b273aaee97543477467b306747880c81f.tar.gz
gentoo-2285858b273aaee97543477467b306747880c81f.tar.bz2
gentoo-2285858b273aaee97543477467b306747880c81f.zip
sys-apps/dtc: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/dtc/dtc-1.4.2.ebuild')
-rw-r--r--sys-apps/dtc/dtc-1.4.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/dtc/dtc-1.4.2.ebuild b/sys-apps/dtc/dtc-1.4.2.ebuild
new file mode 100644
index 000000000000..e6db8eaf45b2
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit multilib toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Open Firmware device tree compiler"
+HOMEPAGE="http://devicetree.org/Device_Tree_Compiler"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+DOCS="
+ Documentation/manual.txt
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+
+ tc-export AR CC
+ export V=1
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}