summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2019-07-04 18:48:59 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2019-07-04 19:06:57 +0000
commitaf3eb37e207a0b63bc7050612622d9f683506a8b (patch)
tree14e920d46b2235f8c83404cd3c4ac8466a893465 /sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild
parentdev-ruby/domain_name: stable 0.5.20180417 for hppa, bug #684546 (diff)
downloadgentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.tar.gz
gentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.tar.bz2
gentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.zip
sys-apps/elivepatch-server: bump to 0.2
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild')
-rw-r--r--sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild b/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild
new file mode 100644
index 000000000000..5707a104f427
--- /dev/null
+++ b/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch building server with RESTFul Api for elivepatch-client"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+SRC_URI="https://github.com/aliceinwire/elivepatch-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-restful[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newinitd init/elivepatch.init ${PN}
+ newconfd init/elivepatch.confd ${PN}
+ distutils-r1_python_install_all
+}