summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/fbset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/fbset')
-rw-r--r--sys-apps/fbset/Manifest1
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild36
-rw-r--r--sys-apps/fbset/files/fbset-2.1-build.patch21
-rw-r--r--sys-apps/fbset/metadata.xml5
4 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/fbset/Manifest b/sys-apps/fbset/Manifest
new file mode 100644
index 000000000000..b16b512cd8b9
--- /dev/null
+++ b/sys-apps/fbset/Manifest
@@ -0,0 +1 @@
+DIST fbset-2.1.tar.gz 27721 SHA256 40ff4ab0247b75138a0887ed40f81c1a6184f340b77126c16d074b1075b41c20 SHA512 7e0380760f77b0db7dcc128f6375a3ed8da4b8521d1926faba27812c5cb20e6f1a62f3a539591a81a6b7e7986940db4cd83e03d6de487e0ab7f0760ed1d21b28 WHIRLPOOL a45b2b1031cd9fc626b318a4df1d697ccc710f86eeba9f7013b738a23f7910d4c73ca5b4bad8ed07a18cf5b60aa8d7a3dbb56424bf56a8346f2c7d94fd97d957
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
new file mode 100644
index 000000000000..a4244f2bde06
--- /dev/null
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="A utility to set the framebuffer videomode"
+HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
+SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin fbset modeline2fb || die "dobin failed"
+ doman *.[58]
+ dodoc etc/fb.modes.* INSTALL
+}
diff --git a/sys-apps/fbset/files/fbset-2.1-build.patch b/sys-apps/fbset/files/fbset-2.1-build.patch
new file mode 100644
index 000000000000..94a323bb39ac
--- /dev/null
+++ b/sys-apps/fbset/files/fbset-2.1-build.patch
@@ -0,0 +1,21 @@
+Index: fbset-2.1/Makefile
+===================================================================
+--- fbset-2.1.orig/Makefile
++++ fbset-2.1/Makefile
+@@ -2,7 +2,6 @@
+ # Linux Frame Buffer Device Configuration
+ #
+
+-CC = gcc -Wall -O2 -I.
+ BISON = bison -d
+ FLEX = flex
+ INSTALL = install
+@@ -20,6 +19,8 @@ lex.yy.o: lex.yy.c fbset.h modes.tab.h
+ lex.yy.c: modes.l
+ $(FLEX) modes.l
+
++modes.tab.h: modes.tab.c
++
+ modes.tab.c: modes.y
+ $(BISON) modes.y
+
diff --git a/sys-apps/fbset/metadata.xml b/sys-apps/fbset/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/fbset/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>