summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-23 07:11:58 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-23 07:15:40 +0200
commit5fbc6165565a91e6d51443f73eccacfafc4065ed (patch)
tree7c098aed6af06069372581b354b31df74d0e5195 /sys-apps/findutils/findutils-4.6.0-r1.ebuild
parentprofiles/package.mask: mask app-admin/lastpass for removal (diff)
downloadgentoo-5fbc6165565a91e6d51443f73eccacfafc4065ed.tar.gz
gentoo-5fbc6165565a91e6d51443f73eccacfafc4065ed.tar.bz2
gentoo-5fbc6165565a91e6d51443f73eccacfafc4065ed.zip
sys-apps/findutils: Fix abort in searching NFS filesystems (bug #580032).
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-apps/findutils/findutils-4.6.0-r1.ebuild')
-rw-r--r--sys-apps/findutils/findutils-4.6.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/findutils/findutils-4.6.0-r1.ebuild b/sys-apps/findutils/findutils-4.6.0-r1.ebuild
new file mode 100644
index 000000000000..196813734052
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.6.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils flag-o-matic toolchain-funcs python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls selinux static test"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Newer C libraries omit this include from sys/types.h.
+ # https://lists.gnu.org/archive/html/bug-gnulib/2016-03/msg00018.html
+ sed -i \
+ '/include.*config.h/a#ifdef MAJOR_IN_SYSMACROS\n#include <sys/sysmacros.h>\n#endif\n' \
+ gl/lib/mountlist.c || die
+
+ epatch "${FILESDIR}"/${P}-gnulib-mb.patch #576818
+ epatch "${FILESDIR}"/${P}-gnulib-S_MAGIC_NFS.patch #580032
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ program_prefix=$(usex userland_GNU '' g)
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/" \
+ --program-prefix=${program_prefix} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ --libexecdir='$(libdir)'/find
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}