summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-01-11 20:49:46 +0100
committerSebastian Pipping <sping@gentoo.org>2017-01-11 20:50:31 +0100
commit8323924482277778d11fb699aa24303338fabdc8 (patch)
treeb676b8dc7f977f04be04ce5ed86255c64950c95e /sys-apps/firejail/firejail-0.9.44.4.ebuild
parentdev-util/ctags: fix autotools conditionals so pkg-config is always found (diff)
downloadgentoo-8323924482277778d11fb699aa24303338fabdc8.tar.gz
gentoo-8323924482277778d11fb699aa24303338fabdc8.tar.bz2
gentoo-8323924482277778d11fb699aa24303338fabdc8.zip
sys-apps/firejail: 0.9.44.4 (bug #604758)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/firejail/firejail-0.9.44.4.ebuild')
-rw-r--r--sys-apps/firejail/firejail-0.9.44.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/firejail/firejail-0.9.44.4.ebuild b/sys-apps/firejail/firejail-0.9.44.4.ebuild
new file mode 100644
index 000000000000..f1b612f0a4cb
--- /dev/null
+++ b/sys-apps/firejail/firejail-0.9.44.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Security sandbox for any type of processes"
+HOMEPAGE="https://firejail.wordpress.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="apparmor +bind +chroot +file-transfer +network
+ network-restricted +seccomp +userns x11"
+
+DEPEND="!sys-apps/firejail-lts
+ apparmor? ( sys-libs/libapparmor )"
+RDEPEND="${DEPEND}
+ x11? ( x11-wm/xpra[client,server] )"
+
+PATCHES=( "${FILESDIR}"/${P}-sysmacros.patch )
+
+src_prepare() {
+ default
+ find -name Makefile.in -exec sed -i -r \
+ -e '/CFLAGS/s: (-O2|-ggdb) : :g' \
+ -e '1iCC=@CC@' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apparmor)
+ $(use_enable bind)
+ $(use_enable chroot)
+ $(use_enable file-transfer)
+ $(use_enable network)
+ $(use_enable seccomp)
+ $(use_enable userns)
+ $(use_enable x11)
+ )
+ use network-restricted && myeconfargs+=( --enable-network=restricted )
+ econf "${myeconfargs[@]}"
+}