summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-18 15:32:40 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-18 15:34:27 -0400
commitbfcdac229e31367086557940b76bb98067e7c5d3 (patch)
tree8f303f98c1b84e3c1e0c2bd9efa3193dc2e5f194 /sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild
parentsys-apps/dbus: arm64 stable (bug 611392). (diff)
downloadgentoo-bfcdac229e31367086557940b76bb98067e7c5d3.tar.gz
gentoo-bfcdac229e31367086557940b76bb98067e7c5d3.tar.bz2
gentoo-bfcdac229e31367086557940b76bb98067e7c5d3.zip
sys-apps/gentoo-functions: bump to 0.12
Package-Manager: Portage-2.3.5_p32, Repoman-2.3.2_p62
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild
new file mode 100644
index 000000000000..654d17b41c1b
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ append-lfs-flags
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}