summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-03-05 14:14:30 -0500
committerMike Gilbert <floppym@gentoo.org>2016-03-05 14:15:32 -0500
commitafd1052fd33d0c5352b763ce9ac1a8699e309020 (patch)
tree914c1c9bc456ea536a912fc2375c63faf828305f /sys-apps/gentoo-systemd-integration
parentsys-apps/gentoo-systemd-integration: Revamp the live ebuild (diff)
downloadgentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.tar.gz
gentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.tar.bz2
gentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.zip
sys-apps/gentoo-systemd-integration: Bump to version 5
Package-Manager: portage-2.2.27_p64
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest1
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
index 5e59ca78471d..edb8b8337bfe 100644
--- a/sys-apps/gentoo-systemd-integration/Manifest
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-systemd-integration-2.tar.bz2 51951 SHA256 2466a11d9b6f6e8d726cb5549bc1c38d28d6742d596e2b2c455c9089c1baf7fd SHA512 dc962165516612ca0ff41fdbd53a420549967a3952640ae7d37aafdbb3543a9b37a928e0528fcbbce74e0ded970e311c350272856fc8a75d9c8dc94a960e3bbc WHIRLPOOL 0517b515b9d01605c46d95fc3e86bf38c200923e3b7df1dde59b875c3eeef232c7dec38833007a943390631cb8eeb4f7c89e79c4b8dab737eea8c63bb36341bf
DIST gentoo-systemd-integration-4.tar.bz2 52449 SHA256 7027bd2056449e5ec8f9fc3da81c0f157810d482bfa11be48903643335fc6bde SHA512 2f60a98062fc5b9c7247e5df77b8875e532d28b2b903a2770713bbcfb2706f0f1bd7809396dd49ff1cc41f69d8c3dceaef87909fa8683c458a5f818f5e05a574 WHIRLPOOL f87b8aa01f24fad4ff90e694fa03b718425bbb0c0dc8a00950b0ae81230f3b92255d07efc9161707a35c8f3e0e7664c57b7ae061ccc0d896bfc55a632a8b4f09
+DIST gentoo-systemd-integration-5.tar.gz 64505 SHA256 5e4245ea6fa857a0a4ee23abb1751a0165e17a7f2136b1822a7a651b51463a41 SHA512 3f4755a680f4df590e86a0ccc12dc48d3c8595248988d573613cd1cedd10ee8cdc5dd4f6b54d15e9be0bef3f69f9546f7e952b0ec22db311e7069cb8599194ad WHIRLPOOL 4ff3d839cba4bc6f24eb2e14d5d0d507ccf873ce34624ef75662a2da3c61a4c63110baec5dc8b9a932bd41d768e7c3ec3cc30a4be07ea135d44f6f7cebf3456d
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild
new file mode 100644
index 000000000000..93648ddc5336
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ econf "${myeconfargs[@]}"
+}