summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-27 18:04:30 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-27 18:04:36 -0500
commit31c16e6d30301f4f5076e9f598a2271b82136621 (patch)
tree0b6a32ebb8884258fb2aee0e733d63bcfc0e7629 /sys-apps/grep
parentmail-mta/exim: amd64 stable wrt bug #602814 (diff)
downloadgentoo-31c16e6d30301f4f5076e9f598a2271b82136621.tar.gz
gentoo-31c16e6d30301f4f5076e9f598a2271b82136621.tar.bz2
gentoo-31c16e6d30301f4f5076e9f598a2271b82136621.zip
sys-apps/grep: add upstream fix for splice errors
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/files/grep-2.27-splice.patch60
-rw-r--r--sys-apps/grep/grep-2.27-r1.ebuild (renamed from sys-apps/grep/grep-2.27.ebuild)1
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/grep/files/grep-2.27-splice.patch b/sys-apps/grep/files/grep-2.27-splice.patch
new file mode 100644
index 000000000000..6c36fe07fd20
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.27-splice.patch
@@ -0,0 +1,60 @@
+http://lists.gnu.org/archive/html/bug-grep/2016-12/msg00036.html
+
+From 7ad47abbcb070946000771a829b51224720b8cef Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Tue, 27 Dec 2016 11:16:32 -0800
+Subject: [PATCH] grep: fix bug with '... | grep pat >> /dev/null'
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Problem reported by Benno Fünfstück (Bug#25283).
+* NEWS: Document this.
+* src/grep.c (drain_input) [SPLICE_F_MOVE]:
+Don't assume /dev/null is always acceptable output to splice.
+* tests/grep-dev-null-out: Test for the bug.
+---
+ NEWS | 7 ++++---
+ src/grep.c | 14 +++++++++-----
+ tests/grep-dev-null-out | 2 ++
+ 3 files changed, 15 insertions(+), 8 deletions(-)
+
+diff --git a/src/grep.c b/src/grep.c
+index f28f3c287609..aebab2060308 100644
+--- a/src/grep.c
++++ b/src/grep.c
+@@ -1728,11 +1728,15 @@ drain_input (int fd, struct stat const *st)
+ {
+ #ifdef SPLICE_F_MOVE
+ /* Should be faster, since it need not copy data to user space. */
+- while ((nbytes = splice (fd, NULL, STDOUT_FILENO, NULL,
+- INITIAL_BUFSIZE, SPLICE_F_MOVE)))
+- if (nbytes < 0)
+- return false;
+- return true;
++ nbytes = splice (fd, NULL, STDOUT_FILENO, NULL,
++ INITIAL_BUFSIZE, SPLICE_F_MOVE);
++ if (0 <= nbytes || errno != EINVAL)
++ {
++ while (0 < nbytes)
++ nbytes = splice (fd, NULL, STDOUT_FILENO, NULL,
++ INITIAL_BUFSIZE, SPLICE_F_MOVE);
++ return nbytes == 0;
++ }
+ #endif
+ }
+ while ((nbytes = safe_read (fd, buffer, bufalloc)))
+diff --git a/tests/grep-dev-null-out b/tests/grep-dev-null-out
+index 13a4843957a6..c8128d5cc6a4 100755
+--- a/tests/grep-dev-null-out
++++ b/tests/grep-dev-null-out
+@@ -8,4 +8,6 @@ require_timeout_
+ ${AWK-awk} 'BEGIN {while (1) print "x"}' </dev/null |
+ returns_ 124 timeout 1 grep x >/dev/null || fail=1
+
++echo abc | grep b >>/dev/null || fail=1
++
+ Exit $fail
+--
+2.11.0
+
diff --git a/sys-apps/grep/grep-2.27.ebuild b/sys-apps/grep/grep-2.27-r1.ebuild
index 845de1d1d3c7..f294f2027315 100644
--- a/sys-apps/grep/grep-2.27.ebuild
+++ b/sys-apps/grep/grep-2.27-r1.ebuild
@@ -28,6 +28,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
src_prepare() {
+ epatch "${FILESDIR}"/${P}-splice.patch
sed -i \
-e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
src/egrep.sh || die #523898